pyqt for 32-bit but not for 64-bit?

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

pyqt for 32-bit but not for 64-bit?

Michael Aye
I must still confuse something with the dependencies for pyqt, i always
thought it's easier to make it run for 64 bit then for 32 bit?
But now I find that the current EPD repo does not offer pyqt for 64-bit
but does offer it for 32-bit?

()[maye@lunatic ~]$
/Library/Frameworks/Python.framework/Versions/7.3/bin/enpkg -s pyqt
Name                   Versions           Product              Note
================================================================================

EuroPython2006_PyQt4_Examples   1.0-1              pypi
PyQt                   4.8.2-1            commercial
                     * 4.8.2-2            commercial
PyQtBindings           0.5.1-1            pypi
                       0.6.1-1            pypi
                       0.6.8-1            pypi
                       0.6.9-1            pypi
pyqterm                0.1-1              pypi
                       0.2-1              pypi
()[maye@lunatic ~]$
/Library/Frameworks/EPD64.framework/Versions/7.3/bin/enpkg -s pyqt
Name                   Versions           Product              Note
================================================================================

EuroPython2006_PyQt4_Examples   1.0-1              pypi
PyQtBindings           0.5.1-1            pypi
                       0.6.1-1            pypi
                       0.6.8-1            pypi
                       0.6.9-1            pypi
pyqterm                0.1-1              pypi
                       0.2-1              pypi


Or is something broken?

Best regards,
Michael



_______________________________________________
Enthought-Dev mailing list
[hidden email]
https://mail.enthought.com/mailman/listinfo/enthought-dev
Reply | Threaded
Open this post in threaded view
|

Re: pyqt for 32-bit but not for 64-bit?

Jonathan March
Michael, you are correct. On OSX, PyQt is available for 32-bit EPD but not yet for 64-bit EPD. PySide, which is available for both 32 and 64, will usually do the job. See: https://support.enthought.com/entries/22961778-EPD-for-Mac-OS-X-32-and-64-bit-versions
hth,
Jonathan


On Tue, Feb 19, 2013 at 7:47 PM, K.-Michael Aye <[hidden email]> wrote:
I must still confuse something with the dependencies for pyqt, i always
thought it's easier to make it run for 64 bit then for 32 bit?
But now I find that the current EPD repo does not offer pyqt for 64-bit
but does offer it for 32-bit?

()[maye@lunatic ~]$
/Library/Frameworks/Python.framework/Versions/7.3/bin/enpkg -s pyqt
Name                   Versions           Product              Note
================================================================================

EuroPython2006_PyQt4_Examples   1.0-1              pypi
PyQt                   4.8.2-1            commercial
                     * 4.8.2-2            commercial
PyQtBindings           0.5.1-1            pypi
                       0.6.1-1            pypi
                       0.6.8-1            pypi
                       0.6.9-1            pypi
pyqterm                0.1-1              pypi
                       0.2-1              pypi
()[maye@lunatic ~]$
/Library/Frameworks/EPD64.framework/Versions/7.3/bin/enpkg -s pyqt
Name                   Versions           Product              Note
================================================================================

EuroPython2006_PyQt4_Examples   1.0-1              pypi
PyQtBindings           0.5.1-1            pypi
                       0.6.1-1            pypi
                       0.6.8-1            pypi
                       0.6.9-1            pypi
pyqterm                0.1-1              pypi
                       0.2-1              pypi


Or is something broken?

Best regards,
Michael



_______________________________________________
Enthought-Dev mailing list
[hidden email]
https://mail.enthought.com/mailman/listinfo/enthought-dev


_______________________________________________
Enthought-Dev mailing list
[hidden email]
https://mail.enthought.com/mailman/listinfo/enthought-dev