problems with MKL on Windows (EPD 6.1)

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

problems with MKL on Windows (EPD 6.1)

Robert Cimrman
Hello!

A colleague of mine has installed EPD 6.1 (academic version) on Windows today,
and encountered the following problem.

OMP abort: Initializing libguide40.lib, but found epdiomp5md.dll already
initialized.
This may cause performance degradation and correctness issues.
Set environment variable KMP_DUPLICATE_LIB_OK=TRUE to ignore
this problem and force the program to continue anyway.
Please note that the use of KMP_DUPLICATE_LIB_OK is unsupported
and using it may cause undefined behavior.
For more information, please contact Intel(R) Premier Support.


A bit of googling resulted in founding [1]. After setting the environment
variables as described there (KMP_DUPLICATE_LIB_OK=TRUE), we have got further -
to MKL FATAL ERROR saying that mkl_serv_lsame is not defined.

Is there a known workaround? Or is it possible to download EPD 6.0 (pre MKL) in
the meantime?

Best regards,
Robert Cimrman

[1] http://forums.adobe.com/message/1811970
_______________________________________________
Enthought-Dev mailing list
[hidden email]
https://mail.enthought.com/mailman/listinfo/enthought-dev
Reply | Threaded
Open this post in threaded view
|

Re: problems with MKL on Windows (EPD 6.1)

Ilan Schnell
Hello,

thanks for reporting the problem.  I have not seen this type of
problem before.
Was EPD installed into a clean directory, i.e. into a location
which didn't previously didn't exist?
Are there other programs (such as matlab) which use the
the MKL runtime installed on the computer?

- Ilan


On Apr 12, 2010, at 9:09 AM, Robert Cimrman wrote:

> Hello!
>
> A colleague of mine has installed EPD 6.1 (academic version) on  
> Windows today,
> and encountered the following problem.
>
> OMP abort: Initializing libguide40.lib, but found epdiomp5md.dll  
> already
> initialized.
> This may cause performance degradation and correctness issues.
> Set environment variable KMP_DUPLICATE_LIB_OK=TRUE to ignore
> this problem and force the program to continue anyway.
> Please note that the use of KMP_DUPLICATE_LIB_OK is unsupported
> and using it may cause undefined behavior.
> For more information, please contact Intel(R) Premier Support.
>
>
> A bit of googling resulted in founding [1]. After setting the  
> environment
> variables as described there (KMP_DUPLICATE_LIB_OK=TRUE), we have  
> got further -
> to MKL FATAL ERROR saying that mkl_serv_lsame is not defined.
>
> Is there a known workaround? Or is it possible to download EPD 6.0  
> (pre MKL) in
> the meantime?
>
> Best regards,
> Robert Cimrman
>
> [1] http://forums.adobe.com/message/1811970
> _______________________________________________
> Enthought-Dev mailing list
> [hidden email]
> https://mail.enthought.com/mailman/listinfo/enthought-dev

_______________________________________________
Enthought-Dev mailing list
[hidden email]
https://mail.enthought.com/mailman/listinfo/enthought-dev
Reply | Threaded
Open this post in threaded view
|

Re: problems with MKL on Windows (EPD 6.1)

Robert Cimrman
There was a previous EPD installation, that the colleague uninstalled before
installing the new version. She did not remove any directory manually though.

Matlab is installed on that computer, can be started and seems to work.

I forgot to mention that the message is printed when trying to generate
documentation by sphinx. It also seems to be triggered by importing pylab.

r.

On 04/12/10 17:46, Ilan Schnell wrote:

> Hello,
>
> thanks for reporting the problem.  I have not seen this type of
> problem before.
> Was EPD installed into a clean directory, i.e. into a location
> which didn't previously didn't exist?
> Are there other programs (such as matlab) which use the
> the MKL runtime installed on the computer?
>
> - Ilan
>
>
> On Apr 12, 2010, at 9:09 AM, Robert Cimrman wrote:
>
>> Hello!
>>
>> A colleague of mine has installed EPD 6.1 (academic version) on
>> Windows today,
>> and encountered the following problem.
>>
>> OMP abort: Initializing libguide40.lib, but found epdiomp5md.dll
>> already
>> initialized.
>> This may cause performance degradation and correctness issues.
>> Set environment variable KMP_DUPLICATE_LIB_OK=TRUE to ignore
>> this problem and force the program to continue anyway.
>> Please note that the use of KMP_DUPLICATE_LIB_OK is unsupported
>> and using it may cause undefined behavior.
>> For more information, please contact Intel(R) Premier Support.
>>
>>
>> A bit of googling resulted in founding [1]. After setting the
>> environment
>> variables as described there (KMP_DUPLICATE_LIB_OK=TRUE), we have
>> got further -
>> to MKL FATAL ERROR saying that mkl_serv_lsame is not defined.
>>
>> Is there a known workaround? Or is it possible to download EPD 6.0
>> (pre MKL) in
>> the meantime?
>>
>> Best regards,
>> Robert Cimrman
>>
>> [1] http://forums.adobe.com/message/1811970
>> _______________________________________________
>> Enthought-Dev mailing list
>> [hidden email]
>> https://mail.enthought.com/mailman/listinfo/enthought-dev
>
> _______________________________________________
> Enthought-Dev mailing list
> [hidden email]
> https://mail.enthought.com/mailman/listinfo/enthought-dev
>

_______________________________________________
Enthought-Dev mailing list
[hidden email]
https://mail.enthought.com/mailman/listinfo/enthought-dev