problem with chaco examples

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

problem with chaco examples

Mohammad Abdollahi
Hi all,

So I've installed Chaco on a 32-bit ubuntu but I can not run Chaco examples and i keep getting errors for that. for example when i try to run the example spectrum.py, i get the following error messages :

Traceback (most recent call last):
  File "spectrum.py", line 18, in <module>
    from enthought.enable.api import Window, Component, ComponentEditor
  File "/usr/lib/python2.6/dist-
packages/enthought/enable/api.py", line 8, in <module>
    from base import IDroppedOnHandler, TOP, VCENTER, BOTTOM, LEFT, HCENTER, RIGHT, \
  File "/usr/lib/python2.6/dist-packages/enthought/enable/base.py", line 42, in <module>
    from colors import color_table, transparent_color
  File "/usr/lib/python2.6/dist-packages/enthought/enable/colors.py", line 175, in <module>
    from enthought.traits.ui.wx.color_editor \
  File "/usr/lib/python2.6/dist-packages/enthought/traits/ui/wx/__init__.py", line 22, in <module>
    __import__('pkg_resources').declare_namespace(__name__)
  File "/usr/lib/python2.6/dist-packages/pkg_resources.py", line 1749, in declare_namespace
    _handle_ns(packageName, path_item)
  File "/usr/lib/python2.6/dist-packages/pkg_resources.py", line 1720, in _handle_ns
    loader.load_module(packageName); module.__path__ = path
  File "/usr/lib/python2.6/pkgutil.py", line 238, in load_module
    mod = imp.load_module(fullname, self.file, self.filename, self.etc)
  File "/usr/local/lib/python2.6/dist-packages/TraitsBackendWX-3.2.1.dev_r0-py2.6.egg/enthought/traits/ui/wx/__init__.py", line 28, in <module>
    import toolkit
  File "/usr/local/lib/python2.6/dist-packages/TraitsBackendWX-3.2.1.dev_r0-py2.6.egg/enthought/traits/ui/wx/toolkit.py", line 27, in <module>
    from enthought.traits.ui.toolkit import assert_toolkit_import
ImportError: cannot import name assert_toolkit_import


Can somebody please help me with this problem ? many thanks in advance.

Kind Regards
Mohammad

_______________________________________________
Enthought-Dev mailing list
[hidden email]
https://mail.enthought.com/mailman/listinfo/enthought-dev
Reply | Threaded
Open this post in threaded view
|

Re: problem with chaco examples

Peter Wang
On 2/15/10 12:04 PM, Mohammad Abdollahi wrote:

>    File
> "/usr/local/lib/python2.6/dist-packages/TraitsBackendWX-3.2.1.dev_r0-py2.6.egg/enthought/traits/ui/wx/__init__.py",
> line 28, in <module>
>      import toolkit
>    File
> "/usr/local/lib/python2.6/dist-packages/TraitsBackendWX-3.2.1.dev_r0-py2.6.egg/enthought/traits/ui/wx/toolkit.py",
> line 27, in <module>
>      from enthought.traits.ui.toolkit import assert_toolkit_import
> ImportError: cannot import name assert_toolkit_import
>
> Can somebody please help me with this problem ? many thanks in advance.

You have a fairly recent version of TraitsBackendWX, but do you have a
correspondingly recent version of the Traits package itself?  The
missing function above was added about 6 months ago to Traits.


-Peter
_______________________________________________
Enthought-Dev mailing list
[hidden email]
https://mail.enthought.com/mailman/listinfo/enthought-dev
Reply | Threaded
Open this post in threaded view
|

Re: problem with chaco examples

Mohammad Abdollahi
thank you Peter for the response. actually i got the whole package of ETS from the SVN which included trait and chaco and the rest all together. but Now I re-installed the whole package again and now that i'm trying to run the same example spectrum.py of chaco i get the following error which is another import problem :

Traceback (most recent call last):
  File "spectrum.py", line 17, in <module>
    from enthought.chaco.default_colormaps import jet
ImportError: No module named chaco.default_colormaps


or when i try to run another example, say data_cube.py, i get this one :

Traceback (most recent call last):
  File "data_cube.py", line 23, in <module>
    from enthought.chaco.api import ArrayPlotData, Plot, GridPlotContainer, \
ImportError: No module named chaco.api


it seems that some packages are not installed correctly here. do have any idea what can be the cause ?

Best
Moahmamd



On Mon, Feb 15, 2010 at 10:31 PM, Peter Wang <[hidden email]> wrote:
On 2/15/10 12:04 PM, Mohammad Abdollahi wrote:
>    File
> "/usr/local/lib/python2.6/dist-packages/TraitsBackendWX-3.2.1.dev_r0-py2.6.egg/enthought/traits/ui/wx/__init__.py",
> line 28, in <module>
>      import toolkit
>    File
> "/usr/local/lib/python2.6/dist-packages/TraitsBackendWX-3.2.1.dev_r0-py2.6.egg/enthought/traits/ui/wx/toolkit.py",
> line 27, in <module>
>      from enthought.traits.ui.toolkit import assert_toolkit_import
> ImportError: cannot import name assert_toolkit_import
>
> Can somebody please help me with this problem ? many thanks in advance.

You have a fairly recent version of TraitsBackendWX, but do you have a
correspondingly recent version of the Traits package itself?  The
missing function above was added about 6 months ago to Traits.


-Peter
_______________________________________________
Enthought-Dev mailing list
[hidden email]
https://mail.enthought.com/mailman/listinfo/enthought-dev


_______________________________________________
Enthought-Dev mailing list
[hidden email]
https://mail.enthought.com/mailman/listinfo/enthought-dev