[mayavi] Text module issue...

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

[mayavi] Text module issue...

fred-2
Hi all,

In the following CME, I set Text module position to (0.5, 0.5, 0.5),
then print it. It displays 0.5, 0.5, 0.5. Good.

Anyway, the Text module in the mayavi tree displays 0, 0, 0.5 (see
snapshot) and it seems that the text does not move in 3D.

Any clue?

TIA.

Cheers,

--
Fred

_______________________________________________
Enthought-Dev mailing list
[hidden email]
https://mail.enthought.com/mailman/listinfo/enthought-dev

cme3D.py (1K) Download Attachment
snapshot.png (164K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: [mayavi] Text module issue... (bis)

fred-2
I get the same strange behavior in 2D too...

TIA.

Cheers,

--
Fred

_______________________________________________
Enthought-Dev mailing list
[hidden email]
https://mail.enthought.com/mailman/listinfo/enthought-dev

snapshot.png (147K) Download Attachment
cme2D.py (1K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: [mayavi] Text module issue...

Gael Varoquaux
In reply to this post by fred-2
On Tue, Feb 08, 2011 at 02:43:49PM +0100, Fred wrote:
> In the following CME, I set Text module position to (0.5, 0.5, 0.5),
> then print it. It displays 0.5, 0.5, 0.5. Good.

> Anyway, the Text module in the mayavi tree displays 0, 0, 0.5 (see
> snapshot) and it seems that the text does not move in 3D.

This problem is trivial:

 1. In your example, the center of the text is almost at the same
    position as the camera target. Thus the text does not seem to move in
    3D, but if you move the camera, you can see that it is indeed
    anchored in 3D.

 2. Move the setting of position_in_3d to after when you define your x,
    y, z positions.

G
_______________________________________________
Enthought-Dev mailing list
[hidden email]
https://mail.enthought.com/mailman/listinfo/enthought-dev
Reply | Threaded
Open this post in threaded view
|

Re: [mayavi] Text module issue...

fred-2
Le 17/04/2011 18:03, Gael Varoquaux a écrit :

> On Tue, Feb 08, 2011 at 02:43:49PM +0100, Fred wrote:
>> In the following CME, I set Text module position to (0.5, 0.5, 0.5),
>> then print it. It displays 0.5, 0.5, 0.5. Good.
>
>> Anyway, the Text module in the mayavi tree displays 0, 0, 0.5 (see
>> snapshot) and it seems that the text does not move in 3D.
>
> This problem is trivial:
>
>   1. In your example, the center of the text is almost at the same
>      position as the camera target. Thus the text does not seem to move in
>      3D, but if you move the camera, you can see that it is indeed
>      anchored in 3D.
>
>   2. Move the setting of position_in_3d to after when you define your x,
>      y, z positions.
Ok, thanks Gaël!

Cheers,

--
Fred
_______________________________________________
Enthought-Dev mailing list
[hidden email]
https://mail.enthought.com/mailman/listinfo/enthought-dev