easy_install help on Ubuntu Karmic, Please?

classic Classic list List threaded Threaded
20 messages Options
Reply | Threaded
Open this post in threaded view
|

easy_install help on Ubuntu Karmic, Please?

Jerzy Jalocha N
Hi, everyone,
I am trying to install Chaco under Ubuntu, but everything seems to
fail. Could someone try to give, clear installation instructions,
please? I've seen on the Internet that many people are struggling with
the installation, which is really very sad!

The python-chaco package from the Ubuntu repository doesn't work at
all. (See my bug report at
https://bugs.launchpad.net/ubuntu/+source/python-chaco/+bug/560111).

The ETS 3.4.0 package from pypi is even worse, because it refuses to
install. (http://pypi.python.org/pypi/ETS/3.4.0)

My system:
 * Xubuntu 9.10 Karmic Koala
 * python2.6 (2.6.4-0ubuntu3)
 * python-setuptools (0.6c9-0ubuntu5)
 * python-numpy (1:1,3.0-3)
 * python-scipy (0.7.0-2)
 * python-vtk (5.2.1-10ubuntu1)
 * python-wxgtk2.8 (2.8.10.1-0ubuntu1)
 * swig (1.3.36-1ubuntu2)
 * g++ (4:4.4.1-1ubuntu2)

First, I tried to install ETS, but it failed with some kind of
permission error(?):

$ sudo easy_install ETS[nonets]
[...]
Installed /usr/local/lib/python2.6/dist-packages/TraitsBackendQt-3.3.0-py2.6.egg
Searching for Traits[nonets]
Reading http://pypi.python.org/simple/Traits/
Reading http://code.enthought.com/projects/traits
Best match: Traits 3.3.0
Downloading http://enthought.com/repo/ets/Traits-3.3.0.tar.gz
Processing Traits-3.3.0.tar.gz
Running Traits-3.3.0/setup.py -q bdist_egg --dist-dir
/tmp/easy_install-Uw2TI3/Traits-3.3.0/egg-dist-tmp-ohalr9
error: Setup script exited with error:
/tmp/easy_install-hLyXCK/TraitsGUI-3.3.0/docs/html.zip: No such file
or directory

Then, I tried to install Chaco, and it went crazy:

$ sudo easy_install Chaco[nonets]
Searching for Chaco[nonets]
Reading http://pypi.python.org/simple/Chaco/
Reading http://code.enthought.com/projects/chaco
Best match: Chaco 3.3.0
Downloading http://www.enthought.com/repo/ETS/Chaco-3.3.0.tar.gz
Processing Chaco-3.3.0.tar.gz
Running Chaco-3.3.0/setup.py -q bdist_egg --dist-dir
/tmp/easy_install-xhGx9o/Chaco-3.3.0/egg-dist-tmp-U0E9m_
Checking .pth file support in .
/usr/bin/python -E -c pass
Searching for setupdocs>=1.0
Reading http://pypi.python.org/simple/setupdocs/
Best match: SetupDocs 1.0.4
Downloading http://pypi.python.org/packages/source/S/SetupDocs/SetupDocs-1.0.4.tar.gz#md5=824bcf896b7e4e7c610d65544e28bdd1
Processing SetupDocs-1.0.4.tar.gz
Running SetupDocs-1.0.4/setup.py -q bdist_egg --dist-dir
/tmp/easy_install-xhGx9o/Chaco-3.3.0/temp/easy_install-cDcly2/SetupDocs-1.0.4/egg-dist-tmp-kyZ_lu
zip_safe flag not set; analyzing archive contents...
setupdocs.setupdocs: module references __file__

Installed /tmp/easy_install-xhGx9o/Chaco-3.3.0/SetupDocs-1.0.4-py2.6.egg
enthought/chaco/contour/cntr.c:17:20: error: Python.h: No such file or directory
enthought/chaco/contour/cntr.c:18:26: error: structmember.h: No such
file or directory
In file included from
/usr/lib/python2.6/dist-packages/numpy/core/include/numpy/ndarrayobject.h:61,
                 from
/usr/lib/python2.6/dist-packages/numpy/core/include/numpy/arrayobject.h:14,
                 from enthought/chaco/contour/cntr.c:23:
/usr/lib/python2.6/dist-packages/numpy/core/include/numpy/npy_common.h:71:2:
error: #error Must use Python with unicode enabled.
In file included from
/usr/lib/python2.6/dist-packages/numpy/core/include/numpy/arrayobject.h:14,
                 from enthought/chaco/contour/cntr.c:23:
/usr/lib/python2.6/dist-packages/numpy/core/include/numpy/ndarrayobject.h:181:
error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before
‘npy_intp’
/usr/lib/python2.6/dist-packages/numpy/core/include/numpy/ndarrayobject.h:182:
error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before
‘npy_uintp’
/usr/lib/python2.6/dist-packages/numpy/core/include/numpy/ndarrayobject.h:284:
error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’
token
/usr/lib/python2.6/dist-packages/numpy/core/include/numpy/ndarrayobject.h:285:
error: expected ‘)’ before ‘*’ token
/usr/lib/python2.6/dist-packages/numpy/core/include/numpy/ndarrayobject.h:287:
error: expected declaration specifiers or ‘...’ before ‘npy_intp’
/usr/lib/python2.6/dist-packages/numpy/core/include/numpy/ndarrayobject.h:287:
error: expected declaration specifiers or ‘...’ before ‘npy_intp’
/usr/lib/python2.6/dist-packages/numpy/core/include/numpy/ndarrayobject.h:288:
error: expected declaration specifiers or ‘...’ before ‘npy_intp’
/usr/lib/python2.6/dist-packages/numpy/core/include/numpy/ndarrayobject.h:298:
error: expected declaration specifiers or ‘...’ before ‘npy_intp’
/usr/lib/python2.6/dist-packages/numpy/core/include/numpy/ndarrayobject.h:298:
error: expected declaration specifiers or ‘...’ before ‘npy_intp’
/usr/lib/python2.6/dist-packages/numpy/core/include/numpy/ndarrayobject.h:300:
error: expected declaration specifiers or ‘...’ before ‘npy_intp’
/usr/lib/python2.6/dist-packages/numpy/core/include/numpy/ndarrayobject.h:300:
error: expected declaration specifiers or ‘...’ before ‘npy_intp’
/usr/lib/python2.6/dist-packages/numpy/core/include/numpy/ndarrayobject.h:301:
error: expected declaration specifiers or ‘...’ before ‘npy_intp’
/usr/lib/python2.6/dist-packages/numpy/core/include/numpy/ndarrayobject.h:303:
error: expected declaration specifiers or ‘...’ before ‘npy_intp’
/usr/lib/python2.6/dist-packages/numpy/core/include/numpy/ndarrayobject.h:313:
error: expected declaration specifiers or ‘...’ before ‘npy_intp’
/usr/lib/python2.6/dist-packages/numpy/core/include/numpy/ndarrayobject.h:315:
error: expected declaration specifiers or ‘...’ before ‘npy_intp’
/usr/lib/python2.6/dist-packages/numpy/core/include/numpy/ndarrayobject.h:316:
error: expected declaration specifiers or ‘...’ before ‘npy_intp’
/usr/lib/python2.6/dist-packages/numpy/core/include/numpy/ndarrayobject.h:316:
error: expected declaration specifiers or ‘...’ before ‘npy_intp’
/usr/lib/python2.6/dist-packages/numpy/core/include/numpy/ndarrayobject.h:318:
error: expected declaration specifiers or ‘...’ before ‘npy_intp’
/usr/lib/python2.6/dist-packages/numpy/core/include/numpy/ndarrayobject.h:322:
error: expected declaration specifiers or ‘...’ before ‘npy_intp’
/usr/lib/python2.6/dist-packages/numpy/core/include/numpy/ndarrayobject.h:324:
error: expected declaration specifiers or ‘...’ before ‘npy_intp’
/usr/lib/python2.6/dist-packages/numpy/core/include/numpy/ndarrayobject.h:325:
error: expected declaration specifiers or ‘...’ before ‘npy_intp’
/usr/lib/python2.6/dist-packages/numpy/core/include/numpy/ndarrayobject.h:326:
error: expected declaration specifiers or ‘...’ before ‘npy_intp’
/usr/lib/python2.6/dist-packages/numpy/core/include/numpy/ndarrayobject.h:327:
error: expected declaration specifiers or ‘...’ before ‘npy_intp’
/usr/lib/python2.6/dist-packages/numpy/core/include/numpy/ndarrayobject.h:327:
error: expected declaration specifiers or ‘...’ before ‘npy_intp’
/usr/lib/python2.6/dist-packages/numpy/core/include/numpy/ndarrayobject.h:328:
error: expected declaration specifiers or ‘...’ before ‘npy_intp’
/usr/lib/python2.6/dist-packages/numpy/core/include/numpy/ndarrayobject.h:328:
error: expected declaration specifiers or ‘...’ before ‘npy_intp’
/usr/lib/python2.6/dist-packages/numpy/core/include/numpy/ndarrayobject.h:332:
error: expected specifier-qualifier-list before ‘npy_intp’
/usr/lib/python2.6/dist-packages/numpy/core/include/numpy/ndarrayobject.h:345:
error: expected specifier-qualifier-list before ‘PyArray_GetItemFunc’
/usr/lib/python2.6/dist-packages/numpy/core/include/numpy/ndarrayobject.h:446:
error: expected specifier-qualifier-list before ‘PyObject_HEAD’
/usr/lib/python2.6/dist-packages/numpy/core/include/numpy/ndarrayobject.h:478:
error: expected specifier-qualifier-list before ‘PyObject’
/usr/lib/python2.6/dist-packages/numpy/core/include/numpy/ndarrayobject.h:488:
error: expected specifier-qualifier-list before ‘PyObject_HEAD’
/usr/lib/python2.6/dist-packages/numpy/core/include/numpy/ndarrayobject.h:513:
error: expected specifier-qualifier-list before ‘PyObject_HEAD’
/usr/lib/python2.6/dist-packages/numpy/core/include/numpy/ndarrayobject.h:521:
error: expected specifier-qualifier-list before ‘PyObject_HEAD’
/usr/lib/python2.6/dist-packages/numpy/core/include/numpy/ndarrayobject.h:528:
error: expected declaration specifiers or ‘...’ before ‘PyObject’
/usr/lib/python2.6/dist-packages/numpy/core/include/numpy/ndarrayobject.h:670:
error: expected specifier-qualifier-list before ‘PyObject_HEAD’
/usr/lib/python2.6/dist-packages/numpy/core/include/numpy/ndarrayobject.h:817:
error: expected specifier-qualifier-list before ‘PyObject_HEAD’
/usr/lib/python2.6/dist-packages/numpy/core/include/numpy/ndarrayobject.h:871:
error: expected specifier-qualifier-list before ‘PyObject_HEAD’
/usr/lib/python2.6/dist-packages/numpy/core/include/numpy/ndarrayobject.h:1084:
error: expected specifier-qualifier-list before ‘npy_intp’
In file included from
/usr/lib/python2.6/dist-packages/numpy/core/include/numpy/ndarrayobject.h:1099,
                 from
/usr/lib/python2.6/dist-packages/numpy/core/include/numpy/arrayobject.h:14,
                 from enthought/chaco/contour/cntr.c:23:
/usr/lib/python2.6/dist-packages/numpy/core/include/numpy/__multiarray_api.h:
In function ‘_import_array’:
/usr/lib/python2.6/dist-packages/numpy/core/include/numpy/__multiarray_api.h:971:
error: ‘PyObject’ undeclared (first use in this function)
/usr/lib/python2.6/dist-packages/numpy/core/include/numpy/__multiarray_api.h:971:
error: (Each undeclared identifier is reported only once
/usr/lib/python2.6/dist-packages/numpy/core/include/numpy/__multiarray_api.h:971:
error: for each function it appears in.)
/usr/lib/python2.6/dist-packages/numpy/core/include/numpy/__multiarray_api.h:971:
error: ‘numpy’ undeclared (first use in this function)
/usr/lib/python2.6/dist-packages/numpy/core/include/numpy/__multiarray_api.h:971:
warning: implicit declaration of function ‘PyImport_ImportModule’
/usr/lib/python2.6/dist-packages/numpy/core/include/numpy/__multiarray_api.h:972:
error: ‘c_api’ undeclared (first use in this function)
/usr/lib/python2.6/dist-packages/numpy/core/include/numpy/__multiarray_api.h:974:
warning: implicit declaration of function ‘PyObject_GetAttrString’
/usr/lib/python2.6/dist-packages/numpy/core/include/numpy/__multiarray_api.h:975:
warning: implicit declaration of function ‘Py_DECREF’
/usr/lib/python2.6/dist-packages/numpy/core/include/numpy/__multiarray_api.h:976:
warning: implicit declaration of function ‘PyCObject_Check’
/usr/lib/python2.6/dist-packages/numpy/core/include/numpy/__multiarray_api.h:977:
warning: implicit declaration of function ‘PyCObject_AsVoidPtr’
/usr/lib/python2.6/dist-packages/numpy/core/include/numpy/__multiarray_api.h:984:
warning: implicit declaration of function ‘PyErr_Format’
/usr/lib/python2.6/dist-packages/numpy/core/include/numpy/__multiarray_api.h:984:
error: ‘PyExc_RuntimeError’ undeclared (first use in this function)
enthought/chaco/contour/cntr.c: In function ‘cntr_new’:
enthought/chaco/contour/cntr.c:1236: warning: implicit declaration of
function ‘PyMem_Malloc’
enthought/chaco/contour/cntr.c: In function ‘cntr_init’:
enthought/chaco/contour/cntr.c:1262: warning: implicit declaration of
function ‘PyMem_Free’
enthought/chaco/contour/cntr.c: At top level:
enthought/chaco/contour/cntr.c:1307: error: expected ‘=’, ‘,’, ‘;’,
‘asm’ or ‘__attribute__’ before ‘*’ token
enthought/chaco/contour/cntr.c:1336: error: expected ‘=’, ‘,’, ‘;’,
‘asm’ or ‘__attribute__’ before ‘*’ token
enthought/chaco/contour/cntr.c:1379: error: expected ‘=’, ‘,’, ‘;’,
‘asm’ or ‘__attribute__’ before ‘*’ token
enthought/chaco/contour/cntr.c:1485: error: expected
specifier-qualifier-list before ‘PyObject_HEAD’
enthought/chaco/contour/cntr.c: In function ‘Cntr_clear’:
enthought/chaco/contour/cntr.c:1496: error: ‘Cntr’ has no member named ‘site’
enthought/chaco/contour/cntr.c:1498: error: ‘Cntr’ has no member named ‘xpa’
enthought/chaco/contour/cntr.c:1499: error: ‘Cntr’ has no member named ‘xpa’
enthought/chaco/contour/cntr.c:1500: warning: implicit declaration of
function ‘Py_XDECREF’
enthought/chaco/contour/cntr.c:1502: error: ‘Cntr’ has no member named ‘ypa’
enthought/chaco/contour/cntr.c:1503: error: ‘Cntr’ has no member named ‘ypa’
enthought/chaco/contour/cntr.c:1506: error: ‘Cntr’ has no member named ‘zpa’
enthought/chaco/contour/cntr.c:1507: error: ‘Cntr’ has no member named ‘zpa’
enthought/chaco/contour/cntr.c:1510: error: ‘Cntr’ has no member named ‘mpa’
enthought/chaco/contour/cntr.c:1511: error: ‘Cntr’ has no member named ‘mpa’
enthought/chaco/contour/cntr.c: In function ‘Cntr_dealloc’:
enthought/chaco/contour/cntr.c:1520: error: ‘Cntr’ has no member named ‘ob_type’
enthought/chaco/contour/cntr.c:1520: error: ‘PyObject’ undeclared
(first use in this function)
enthought/chaco/contour/cntr.c:1520: error: expected expression before ‘)’ token
enthought/chaco/contour/cntr.c: At top level:
enthought/chaco/contour/cntr.c:1523: error: expected ‘=’, ‘,’, ‘;’,
‘asm’ or ‘__attribute__’ before ‘*’ token
enthought/chaco/contour/cntr.c:1549: error: expected declaration
specifiers or ‘...’ before ‘PyObject’
enthought/chaco/contour/cntr.c:1549: error: expected declaration
specifiers or ‘...’ before ‘PyObject’
enthought/chaco/contour/cntr.c: In function ‘Cntr_init’:
enthought/chaco/contour/cntr.c:1551: error: ‘PyObject’ undeclared
(first use in this function)
enthought/chaco/contour/cntr.c:1551: error: ‘xarg’ undeclared (first
use in this function)
enthought/chaco/contour/cntr.c:1551: error: ‘yarg’ undeclared (first
use in this function)
enthought/chaco/contour/cntr.c:1551: warning: left-hand operand of
comma expression has no effect
enthought/chaco/contour/cntr.c:1551: error: ‘zarg’ undeclared (first
use in this function)
enthought/chaco/contour/cntr.c:1551: warning: left-hand operand of
comma expression has no effect
enthought/chaco/contour/cntr.c:1551: error: ‘marg’ undeclared (first
use in this function)
enthought/chaco/contour/cntr.c:1551: warning: left-hand operand of
comma expression has no effect
enthought/chaco/contour/cntr.c:1559: warning: implicit declaration of
function ‘PyArg_ParseTupleAndKeywords’
enthought/chaco/contour/cntr.c:1559: error: ‘args’ undeclared (first
use in this function)
enthought/chaco/contour/cntr.c:1559: error: ‘kwds’ undeclared (first
use in this function)
enthought/chaco/contour/cntr.c:1562: error: ‘Py_None’ undeclared
(first use in this function)
enthought/chaco/contour/cntr.c:1565: warning: implicit declaration of
function ‘PyObject_TypeCheck’
enthought/chaco/contour/cntr.c:1565: error: ‘PyTypeObject’ undeclared
(first use in this function)
enthought/chaco/contour/cntr.c:1565: error: expected expression before ‘)’ token
enthought/chaco/contour/cntr.c:1565: error: expected expression before ‘)’ token
enthought/chaco/contour/cntr.c:1566: error: expected expression before ‘)’ token
enthought/chaco/contour/cntr.c:1566: error: expected expression before ‘)’ token
enthought/chaco/contour/cntr.c:1568: warning: implicit declaration of
function ‘PyErr_SetString’
enthought/chaco/contour/cntr.c:1568: error: ‘PyExc_TypeError’
undeclared (first use in this function)
enthought/chaco/contour/cntr.c:1573: error: expected expression before ‘)’ token
enthought/chaco/contour/cntr.c:1573: error: expected ‘)’ before ‘PyArray_API’
enthought/chaco/contour/cntr.c:1574: error: expected expression before ‘)’ token
enthought/chaco/contour/cntr.c:1574: error: expected ‘)’ before ‘PyArray_API’
enthought/chaco/contour/cntr.c:1575: error: expected expression before ‘)’ token
enthought/chaco/contour/cntr.c:1575: error: expected ‘)’ before ‘PyArray_API’
enthought/chaco/contour/cntr.c:1577: error: expected expression before ‘)’ token
enthought/chaco/contour/cntr.c:1577: error: expected ‘)’ before ‘PyArray_API’
enthought/chaco/contour/cntr.c:1583: error: ‘PyExc_ValueError’
undeclared (first use in this function)
enthought/chaco/contour/cntr.c:1587: error: ‘PyArrayObject’ has no
member named ‘dimensions’
enthought/chaco/contour/cntr.c:1588: error: ‘PyArrayObject’ has no
member named ‘dimensions’
enthought/chaco/contour/cntr.c:1589: error: ‘PyArrayObject’ has no
member named ‘dimensions’
enthought/chaco/contour/cntr.c:1589: error: ‘PyArrayObject’ has no
member named ‘dimensions’
enthought/chaco/contour/cntr.c:1590: error: ‘PyArrayObject’ has no
member named ‘dimensions’
enthought/chaco/contour/cntr.c:1590: error: ‘PyArrayObject’ has no
member named ‘dimensions’
enthought/chaco/contour/cntr.c:1591: error: ‘PyArrayObject’ has no
member named ‘dimensions’
enthought/chaco/contour/cntr.c:1591: error: ‘PyArrayObject’ has no
member named ‘dimensions’
enthought/chaco/contour/cntr.c:1598: error: ‘PyArrayObject’ has no
member named ‘data’
enthought/chaco/contour/cntr.c:1600: error: ‘Cntr’ has no member named ‘site’
enthought/chaco/contour/cntr.c:1600: error: ‘PyArrayObject’ has no
member named ‘data’
enthought/chaco/contour/cntr.c:1601: error: ‘PyArrayObject’ has no
member named ‘data’
enthought/chaco/contour/cntr.c:1602: error: ‘PyArrayObject’ has no
member named ‘data’
enthought/chaco/contour/cntr.c:1604: error: ‘PyExc_MemoryError’
undeclared (first use in this function)
enthought/chaco/contour/cntr.c:1608: error: ‘Cntr’ has no member named ‘xpa’
enthought/chaco/contour/cntr.c:1609: error: ‘Cntr’ has no member named ‘ypa’
enthought/chaco/contour/cntr.c:1610: error: ‘Cntr’ has no member named ‘zpa’
enthought/chaco/contour/cntr.c:1611: error: ‘Cntr’ has no member named ‘mpa’
enthought/chaco/contour/cntr.c: At top level:
enthought/chaco/contour/cntr.c:1622: error: expected ‘=’, ‘,’, ‘;’,
‘asm’ or ‘__attribute__’ before ‘*’ token
enthought/chaco/contour/cntr.c:1640: error: expected ‘=’, ‘,’, ‘;’,
‘asm’ or ‘__attribute__’ before ‘Cntr_methods’
enthought/chaco/contour/cntr.c:1653: error: expected ‘=’, ‘,’, ‘;’,
‘asm’ or ‘__attribute__’ before ‘CntrType’
enthought/chaco/contour/cntr.c:1695: error: expected ‘=’, ‘,’, ‘;’,
‘asm’ or ‘__attribute__’ before ‘module_methods’
enthought/chaco/contour/cntr.c:1722: error: expected ‘=’, ‘,’, ‘;’,
‘asm’ or ‘__attribute__’ before ‘initcontour’
error: Setup script exited with error: command 'gcc' failed with exit status 1
_______________________________________________
Enthought-Dev mailing list
[hidden email]
https://mail.enthought.com/mailman/listinfo/enthought-dev
Reply | Threaded
Open this post in threaded view
|

Re: easy_install help on Ubuntu Karmic, Please?

Robert Kern
On Sat, Apr 10, 2010 at 12:27 PM, Jerzy Jalocha N <[hidden email]> wrote:

> Hi, everyone,
> I am trying to install Chaco under Ubuntu, but everything seems to
> fail. Could someone try to give, clear installation instructions,
> please? I've seen on the Internet that many people are struggling with
> the installation, which is really very sad!
>
> The python-chaco package from the Ubuntu repository doesn't work at
> all. (See my bug report at
> https://bugs.launchpad.net/ubuntu/+source/python-chaco/+bug/560111).
>
> The ETS 3.4.0 package from pypi is even worse, because it refuses to
> install. (http://pypi.python.org/pypi/ETS/3.4.0)
>
> My system:
>  * Xubuntu 9.10 Karmic Koala
>  * python2.6 (2.6.4-0ubuntu3)
>  * python-setuptools (0.6c9-0ubuntu5)
>  * python-numpy (1:1,3.0-3)
>  * python-scipy (0.7.0-2)
>  * python-vtk (5.2.1-10ubuntu1)
>  * python-wxgtk2.8 (2.8.10.1-0ubuntu1)
>  * swig (1.3.36-1ubuntu2)
>  * g++ (4:4.4.1-1ubuntu2)

> Installed /tmp/easy_install-xhGx9o/Chaco-3.3.0/SetupDocs-1.0.4-py2.6.egg
> enthought/chaco/contour/cntr.c:17:20: error: Python.h: No such file or directory

You will also need the appropriate Python development package installed.

$ sudo apt-get install python-dev

--
Robert Kern

"I have come to believe that the whole world is an enigma, a harmless
enigma that is made terrible by our own mad attempt to interpret it as
though it had an underlying truth."
  -- Umberto Eco
_______________________________________________
Enthought-Dev mailing list
[hidden email]
https://mail.enthought.com/mailman/listinfo/enthought-dev
Reply | Threaded
Open this post in threaded view
|

Re: easy_install help on Ubuntu Karmic, Please?

Jerzy Jalocha N
>> I am trying to install Chaco under Ubuntu, but everything seems to
>> fail. Could someone try to give, clear installation instructions,
[...]

>>
>> My system:
>>  * Xubuntu 9.10 Karmic Koala
>>  * python2.6 (2.6.4-0ubuntu3)
>>  * python-setuptools (0.6c9-0ubuntu5)
>>  * python-numpy (1:1,3.0-3)
>>  * python-scipy (0.7.0-2)
>>  * python-vtk (5.2.1-10ubuntu1)
>>  * python-wxgtk2.8 (2.8.10.1-0ubuntu1)
>>  * swig (1.3.36-1ubuntu2)
>>  * g++ (4:4.4.1-1ubuntu2)
>
>> Installed /tmp/easy_install-xhGx9o/Chaco-3.3.0/SetupDocs-1.0.4-py2.6.egg
>> enthought/chaco/contour/cntr.c:17:20: error: Python.h: No such file or directory
>
> You will also need the appropriate Python development package installed.

Robert, thanks for your input.
Sadly, after installing python-dev, both ETS and Chaco still fail to
install.Actually, the easy_install script seems to be broken for
Chaco, according to the error message.

$ sudo easy_install ETS[nonets]
Searching for ETS[nonets]
Best match: ETS 3.4.0
Processing ETS-3.4.0-py2.6.egg
ETS 3.4.0 is already the active version in easy-install.pth

Using /usr/local/lib/python2.6/dist-packages/ETS-3.4.0-py2.6.egg
Processing dependencies for ETS[nonets]
Searching for Traits[nonets]
Reading http://pypi.python.org/simple/Traits/
Reading http://code.enthought.com/projects/traits
Best match: Traits 3.3.0
Downloading http://enthought.com/repo/ets/Traits-3.3.0.tar.gz
Processing Traits-3.3.0.tar.gz
Running Traits-3.3.0/setup.py -q bdist_egg --dist-dir
/tmp/easy_install-Yx8xjD/Traits-3.3.0/egg-dist-tmp-P78bKa
Checking .pth file support in .
/usr/bin/python -E -c pass
Searching for setupdocs>=1.0
Reading http://pypi.python.org/simple/setupdocs/
Best match: SetupDocs 1.0.4
Downloading http://pypi.python.org/packages/source/S/SetupDocs/SetupDocs-1.0.4.tar.gz#md5=824bcf896b7e4e7c610d65544e28bdd1
Processing SetupDocs-1.0.4.tar.gz
Running SetupDocs-1.0.4/setup.py -q bdist_egg --dist-dir
/tmp/easy_install-Yx8xjD/Traits-3.3.0/temp/easy_install-YphxrH/SetupDocs-1.0.4/egg-dist-tmp-sRjnOs
zip_safe flag not set; analyzing archive contents...
setupdocs.setupdocs: module references __file__

Installed /tmp/easy_install-Yx8xjD/Traits-3.3.0/SetupDocs-1.0.4-py2.6.egg
enthought/traits/protocols/_speedups.c: In function
‘__pyx_f_9enthought_6traits_9protocols_9_speedups_buildClassicMRO’:
enthought/traits/protocols/_speedups.c:1930: warning: passing argument
1 of ‘PyList_Append’ from incompatible pointer type
/usr/include/python2.6/listobject.h:52: note: expected ‘struct
PyObject *’ but argument is of type ‘struct PyListObject *’
enthought/traits/protocols/_speedups.c:1939: warning: assignment from
incompatible pointer type
enthought/traits/protocols/_speedups.c: In function
‘__pyx_pf_9enthought_6traits_9protocols_9_speedups_classicMRO’:
enthought/traits/protocols/_speedups.c:2122: warning: passing argument
1 of ‘PyList_Append’ from incompatible pointer type
/usr/include/python2.6/listobject.h:52: note: expected ‘struct
PyObject *’ but argument is of type ‘struct PyListObject *’
enthought/traits/protocols/_speedups.c:2132: warning: passing argument
1 of ‘PyList_Append’ from incompatible pointer type
/usr/include/python2.6/listobject.h:52: note: expected ‘struct
PyObject *’ but argument is of type ‘struct PyListObject *’
enthought/traits/protocols/_speedups.c: In function
‘__pyx_f_9enthought_6traits_9protocols_9_speedups_buildECMRO’:
enthought/traits/protocols/_speedups.c:2216: warning: passing argument
1 of ‘PyList_Append’ from incompatible pointer type
/usr/include/python2.6/listobject.h:52: note: expected ‘struct
PyObject *’ but argument is of type ‘struct PyListObject *’
enthought/traits/protocols/_speedups.c: In function
‘__pyx_pf_9enthought_6traits_9protocols_9_speedups_extClassMRO’:
enthought/traits/protocols/_speedups.c:2391: warning: passing argument
1 of ‘PyList_Append’ from incompatible pointer type
/usr/include/python2.6/listobject.h:52: note: expected ‘struct
PyObject *’ but argument is of type ‘struct PyListObject *’
enthought/traits/protocols/_speedups.c:2401: warning: passing argument
1 of ‘PyList_Append’ from incompatible pointer type
/usr/include/python2.6/listobject.h:52: note: expected ‘struct
PyObject *’ but argument is of type ‘struct PyListObject *’
enthought/traits/protocols/_speedups.c: In function
‘__pyx_pf_9enthought_6traits_9protocols_9_speedups_getMRO’:
enthought/traits/protocols/_speedups.c:2569: warning: comparison of
distinct pointer types lacks a cast
enthought/traits/protocols/_speedups.c:2569: warning: passing argument
2 of ‘PyType_IsSubtype’ from incompatible pointer type
/usr/include/python2.6/object.h:435: note: expected ‘struct
PyTypeObject *’ but argument is of type ‘struct PyObject *’
enthought/traits/protocols/_speedups.c: In function
‘__pyx_pf_9enthought_6traits_9protocols_9_speedups_Protocol__adapt__’:
enthought/traits/protocols/_speedups.c:2937: warning: passing argument
1 of ‘PyList_Append’ from incompatible pointer type
/usr/include/python2.6/listobject.h:52: note: expected ‘struct
PyObject *’ but argument is of type ‘struct PyListObject *’
enthought/traits/protocols/_speedups.c:2947: warning: passing argument
1 of ‘PyList_Append’ from incompatible pointer type
/usr/include/python2.6/listobject.h:52: note: expected ‘struct
PyObject *’ but argument is of type ‘struct PyListObject *’
enthought/traits/protocols/_speedups.c:3011: warning: comparison of
distinct pointer types lacks a cast
enthought/traits/protocols/_speedups.c:3011: warning: passing argument
2 of ‘PyType_IsSubtype’ from incompatible pointer type
/usr/include/python2.6/object.h:435: note: expected ‘struct
PyTypeObject *’ but argument is of type ‘struct PyObject *’
Adding Traits 3.3.0 to easy-install.pth file

Installed /usr/local/lib/python2.6/dist-packages/Traits-3.3.0-py2.6-linux-i686.egg
Searching for SetupDocs[nonets]
Reading http://pypi.python.org/simple/SetupDocs/
Best match: SetupDocs 1.0.4
Downloading http://pypi.python.org/packages/source/S/SetupDocs/SetupDocs-1.0.4.tar.gz#md5=824bcf896b7e4e7c610d65544e28bdd1
Processing SetupDocs-1.0.4.tar.gz
Running SetupDocs-1.0.4/setup.py -q bdist_egg --dist-dir
/tmp/easy_install-Ed_Ue7/SetupDocs-1.0.4/egg-dist-tmp-EfwVuN
zip_safe flag not set; analyzing archive contents...
setupdocs.setupdocs: module references __file__
Adding SetupDocs 1.0.4 to easy-install.pth file

Installed /usr/local/lib/python2.6/dist-packages/SetupDocs-1.0.4-py2.6.egg
Searching for SciMath[nonets]
Reading http://pypi.python.org/simple/SciMath/
Reading http://code.enthought.com/projects/sci_math.php
Best match: SciMath 3.0.5
Downloading http://pypi.python.org/packages/source/S/SciMath/SciMath-3.0.5.tar.gz#md5=8ee67025cf230e34990f4a46c40bd3b6
Processing SciMath-3.0.5.tar.gz
Running SciMath-3.0.5/setup.py -q bdist_egg --dist-dir
/tmp/easy_install-f7o4jo/SciMath-3.0.5/egg-dist-tmp-LCe0yn
Warning: distutils distribution has been initialized, it may be too
late to add an extension _interpolate
Warning: distutils distribution has been initialized, it may be too
late to add a subpackage enthought.interpolate
Warning: distutils distribution has been initialized, it may be too
late to add a subpackage enthought
error: Setup script exited with error:
/tmp/easy_install-Yx8xjD/Traits-3.3.0/docs/html.zip: No such file or
directory
$


$ sudo easy_install Chaco[nonets]
Searching for Chaco[nonets]
Reading http://pypi.python.org/simple/Chaco/
Reading http://code.enthought.com/projects/chaco
Best match: Chaco 3.3.0
Downloading http://www.enthought.com/repo/ETS/Chaco-3.3.0.tar.gz
Processing Chaco-3.3.0.tar.gz
Running Chaco-3.3.0/setup.py -q bdist_egg --dist-dir
/tmp/easy_install-R1KuK1/Chaco-3.3.0/egg-dist-tmp-miWSFB
Adding Chaco 3.3.0 to easy-install.pth file

Installed /usr/local/lib/python2.6/dist-packages/Chaco-3.3.0-py2.6-linux-i686.egg
Processing dependencies for Chaco[nonets]
Searching for EnthoughtBase>=3.0.4.dev
Reading http://pypi.python.org/simple/EnthoughtBase/
Reading http://code.enthought.com/projects/enthought_base.php
Best match: EnthoughtBase 3.0.4
Downloading http://pypi.python.org/packages/source/E/EnthoughtBase/EnthoughtBase-3.0.4.tar.gz#md5=0e62eddfa37995a1956c648e06213132
Processing EnthoughtBase-3.0.4.tar.gz
Running EnthoughtBase-3.0.4/setup.py -q bdist_egg --dist-dir
/tmp/easy_install-rjCdoY/EnthoughtBase-3.0.4/egg-dist-tmp-KBdjJY
error: Setup script exited with error: SandboxViolation:
open('/tmp/easy_install-R1KuK1/Chaco-3.3.0/build/docs/html/_images/bar_plot.png',
'wb') {}

The package setup script has attempted to modify files on your system
that are not within the EasyInstall build area, and has been aborted.

This package cannot be safely installed by EasyInstall, and may not
support alternate installation locations even if you run its setup
script by hand.  Please inform the package's author and the EasyInstall
maintainers to find out if a fix or workaround is available.
$
_______________________________________________
Enthought-Dev mailing list
[hidden email]
https://mail.enthought.com/mailman/listinfo/enthought-dev
Reply | Threaded
Open this post in threaded view
|

Re: easy_install help on Ubuntu Karmic, Please?

Robert Kern
On Sat, Apr 10, 2010 at 6:55 PM, Jerzy Jalocha N <[hidden email]> wrote:
> Sadly, after installing python-dev, both ETS and Chaco still fail to
> install.Actually, the easy_install script seems to be broken for
> Chaco, according to the error message.

> error: Setup script exited with error: SandboxViolation:
> open('/tmp/easy_install-R1KuK1/Chaco-3.3.0/build/docs/html/_images/bar_plot.png',
> 'wb') {}
>
> The package setup script has attempted to modify files on your system
> that are not within the EasyInstall build area, and has been aborted.
>
> This package cannot be safely installed by EasyInstall, and may not
> support alternate installation locations even if you run its setup
> script by hand.  Please inform the package's author and the EasyInstall
> maintainers to find out if a fix or workaround is available.

This is a known issue, but it is difficult to replicate and track
down. Usually, you can just try again, and it will work (thus the
problem with replicating it).

--
Robert Kern

"I have come to believe that the whole world is an enigma, a harmless
enigma that is made terrible by our own mad attempt to interpret it as
though it had an underlying truth."
  -- Umberto Eco
_______________________________________________
Enthought-Dev mailing list
[hidden email]
https://mail.enthought.com/mailman/listinfo/enthought-dev
Reply | Threaded
Open this post in threaded view
|

Re: easy_install help on Ubuntu Karmic, Please?

Peter Wang
The strange part about the following problem is... why is the
EnthoughtBase doing *anything* with the Chaco HTML docs directory?  Is
this just easy_install itself being stupid?  Or are we installing some
setup_docs sort of extension to setuptools that causes this mingling?

> Running EnthoughtBase-3.0.4/setup.py -q bdist_egg --dist-dir
> /tmp/easy_install-rjCdoY/EnthoughtBase-3.0.4/egg-dist-tmp-KBdjJY
> error: Setup script exited with error: SandboxViolation:
> open('/tmp/easy_install-R1KuK1/Chaco-3.3.0/build/docs/html/_images/bar_plot.png',
'wb') {}


-Peter
_______________________________________________
Enthought-Dev mailing list
[hidden email]
https://mail.enthought.com/mailman/listinfo/enthought-dev
Reply | Threaded
Open this post in threaded view
|

Re: easy_install help on Ubuntu Karmic, Please?

Jerzy Jalocha N
In reply to this post by Robert Kern
>> $ sudo easy_install Chaco[nonets]
[...]

>> error: Setup script exited with error: SandboxViolation:
>> open('/tmp/easy_install-R1KuK1/Chaco-3.3.0/build/docs/html/_images/bar_plot.png',
>> 'wb') {}
>>
>> The package setup script has attempted to modify files on your system
>> that are not within the EasyInstall build area, and has been aborted.
>>
>> This package cannot be safely installed by EasyInstall, and may not
>> support alternate installation locations even if you run its setup
>> script by hand.  Please inform the package's author and the EasyInstall
>> maintainers to find out if a fix or workaround is available.
>
> This is a known issue, but it is difficult to replicate and track
> down. Usually, you can just try again, and it will work (thus the
> problem with replicating it).

OK, I ran easy_install some more times, and I installed the missing
'python-pyrex' package (using the --without-recommends option, in
order to avoid installing 'python-all' and 'python-all-dev').

I also installed 'python-xlib', but It still complains about missing
X11 libraries.

When I repeat the easy_install command now, I always get exactly the
same error output.


$ sudo easy_install Chaco[nonets]
Searching for Chaco[nonets]
Best match: Chaco 3.3.0
Processing Chaco-3.3.0-py2.6-linux-i686.egg
Chaco 3.3.0 is already the active version in easy-install.pth

Using /usr/local/lib/python2.6/dist-packages/Chaco-3.3.0-py2.6-linux-i686.egg
Processing dependencies for Chaco[nonets]
Searching for Enable[traits]>=3.3.0.dev
Reading http://pypi.python.org/simple/Enable/
Reading http://code.enthought.com/projects/enable
Best match: Enable 3.3.0
Downloading http://enthought.com/repo/ets/Enable-3.3.0.tar.gz
Processing Enable-3.3.0.tar.gz
Running Enable-3.3.0/setup.py -q bdist_egg --dist-dir
/tmp/easy_install-YsSgGI/Enable-3.3.0/egg-dist-tmp-tM1xb9
/usr/lib/python2.6/dist-packages/numpy/distutils/system_info.py:452:
UserWarning: X11 libraries not found.
  warnings.warn(self.notfounderror.__doc__)
package init file './enthought/savage/traits/ui/wx/data/__init__.py'
not found (or not a regular file)
package init file './enthought/savage/traits/ui/wx/data/__init__.py'
not found (or not a regular file)
package init file './enthought/savage/traits/ui/wx/data/__init__.py'
not found (or not a regular file)
enthought/kiva/agg/agg-24/src/agg_curves.cpp:245: warning: ‘double
agg::MSC60_fix_ICE(double)’ defined but not used
enthought/kiva/agg/agg-24/include/agg_trans_double_path.h: In
constructor ‘agg::trans_double_path::trans_double_path()’:
enthought/kiva/agg/agg-24/include/agg_trans_double_path.h:122:
warning: ‘agg::trans_double_path::m_kindex2’ will be initialized after
enthought/kiva/agg/agg-24/include/agg_trans_double_path.h:119:
warning:   ‘double agg::trans_double_path::m_base_length’
enthought/kiva/agg/agg-24/src/agg_trans_double_path.cpp:23: warning:
when initialized here
enthought/kiva/agg/agg-24/src/agg_gsv_text.cpp: In member function
‘void agg::gsv_text::load_font(const char*)’:
enthought/kiva/agg/agg-24/src/agg_gsv_text.cpp:559: warning: ignoring
return value of ‘size_t fread(void*, size_t, size_t, FILE*)’, declared
with attribute warn_unused_result
enthought/kiva/agg/src/kiva_hit_test.cpp: In function ‘bool
kiva::toggle_odd_node(double, double, double, double, double,
double)’:
enthought/kiva/agg/src/kiva_hit_test.cpp:27: warning: suggest
parentheses around ‘&&’ within ‘||’
In file included from enthought/kiva/agg/src/gl_graphics_context.cpp:13:
enthought/kiva/agg/src/gl_graphics_context.h:15:20: error: GL/gl.h: No
such file or directory
enthought/kiva/agg/src/gl_graphics_context.h:16:21: error: GL/glu.h:
No such file or directory
In file included from enthought/kiva/agg/src/gl_graphics_context.cpp:13:
enthought/kiva/agg/src/gl_graphics_context.h:111: error: ‘GLuint’ has
not been declared
enthought/kiva/agg/src/gl_graphics_context.h:113: error: ‘GLuint’ has
not been declared
enthought/kiva/agg/src/gl_graphics_context.h:113: error: ‘GLuint’ has
not been declared
enthought/kiva/agg/src/gl_graphics_context.h:122: error: ‘GLuint’ does
not name a type
enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
‘void kiva::gl_graphics_context::gl_init()’:
enthought/kiva/agg/src/gl_graphics_context.cpp:43: error: ‘glViewport’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:44: error:
‘GL_PROJECTION’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:44: error:
‘glMatrixMode’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:45: error:
‘glLoadIdentity’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:46: error: ‘glOrtho’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:47: error:
‘GL_MODELVIEW’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:52: error:
‘GL_SCISSOR_TEST’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:52: error: ‘glEnable’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:55: error: ‘GL_BLEND’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:56: error:
‘GL_SRC_ALPHA’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:56: error:
‘GL_ONE_MINUS_SRC_ALPHA’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:56: error:
‘glBlendFunc’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:57: error:
‘GL_LINE_SMOOTH_HINT’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:57: error:
‘GL_DONT_CARE’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:57: error: ‘glHint’ was
not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:58: error:
‘GL_POLYGON_SMOOTH_HINT’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:64: error: ‘glScissor’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
‘void kiva::gl_graphics_context::save_state()’:
enthought/kiva/agg/src/gl_graphics_context.cpp:83: error:
‘GL_MODELVIEW’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:83: error:
‘glMatrixMode’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:84: error:
‘glPushMatrix’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
‘virtual void kiva::gl_graphics_context::restore_state()’:
enthought/kiva/agg/src/gl_graphics_context.cpp:113: error: ‘glScissor’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:122: error:
‘GL_MODELVIEW’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:122: error:
‘glMatrixMode’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:123: error:
‘glPopMatrix’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
‘void kiva::gl_graphics_context::begin_page()’:
enthought/kiva/agg/src/gl_graphics_context.cpp:129: error:
‘glClearColor’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:130: error:
‘GL_COLOR_BUFFER_BIT’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:130: error: ‘glClear’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
‘virtual void kiva::gl_graphics_context::clip_to_rect(kiva::rect_type&)’:
enthought/kiva/agg/src/gl_graphics_context.cpp:167: error: ‘glScissor’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:174: error: ‘glScissor’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:188: error: ‘glScissor’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:199: error: ‘glScissor’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
‘virtual void kiva::gl_graphics_context::clear_clip_path()’:
enthought/kiva/agg/src/gl_graphics_context.cpp:225: error: ‘glScissor’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
‘virtual void kiva::gl_graphics_context::clear(agg::rgba)’:
enthought/kiva/agg/src/gl_graphics_context.cpp:280: error:
‘glClearColor’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:281: error:
‘GL_COLOR_BUFFER_BIT’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:281: error: ‘glClear’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
‘void kiva::gl_graphics_context::gl_render_path(kiva::compiled_path*,
bool, bool)’:
enthought/kiva/agg/src/gl_graphics_context.cpp:316: error:
‘GL_MODELVIEW’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:316: error:
‘glMatrixMode’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:324: error:
‘GL_POLYGON’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:324: error: ‘glBegin’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:332: error:
‘GL_LINE_LOOP’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:332: error: ‘glBegin’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:338: error:
‘GL_LINE_STRIP’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:338: error: ‘glBegin’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:348: error: ‘GLfloat’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:348: error: expected
‘;’ before ‘vvx’
enthought/kiva/agg/src/gl_graphics_context.cpp:364: error: expected
‘)’ before ‘x0’
enthought/kiva/agg/src/gl_graphics_context.cpp:364: error: expected
‘)’ before ‘y0’
enthought/kiva/agg/src/gl_graphics_context.cpp:364: error:
‘glVertex2f’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:367: error: expected
‘)’ before ‘vx’
enthought/kiva/agg/src/gl_graphics_context.cpp:367: error: expected
‘)’ before ‘vy’
enthought/kiva/agg/src/gl_graphics_context.cpp:367: error:
‘glVertex2f’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:381: error: expected
‘)’ before ‘x0’
enthought/kiva/agg/src/gl_graphics_context.cpp:381: error: expected
‘)’ before ‘y0’
enthought/kiva/agg/src/gl_graphics_context.cpp:398: error: ‘vvx’ was
not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:399: error: ‘vvy’ was
not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:407: error: expected
‘)’ before ‘x0’
enthought/kiva/agg/src/gl_graphics_context.cpp:407: error: expected
‘)’ before ‘y0’
enthought/kiva/agg/src/gl_graphics_context.cpp:421: error: ‘vvx’ was
not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:422: error: ‘vvy’ was
not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:429: error: ‘glEnd’ was
not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:433: error:
‘GL_POLYGON’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:433: error: ‘glBegin’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:435: error:
‘GL_LINE_LOOP’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:435: error: ‘glBegin’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:439: error:
‘GL_LINE_STRIP’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:439: error: ‘glBegin’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:462: error: ‘glEnd’ was
not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
‘virtual void kiva::gl_graphics_context::draw_path(kiva::draw_mode_e)’:
enthought/kiva/agg/src/gl_graphics_context.cpp:485: error:
‘GL_LINE_SMOOTH’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:485: error: ‘glEnable’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:486: error:
‘GL_POLYGON_SMOOTH’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:490: error:
‘GL_LINE_SMOOTH’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:490: error: ‘glDisable’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:491: error:
‘GL_POLYGON_SMOOTH’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:531: error: ‘glColor4f’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:543: error: ‘glColor4f’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:544: error:
‘glLineWidth’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:548: error:
‘GL_LINE_STIPPLE’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:548: error: ‘glDisable’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:552: error:
‘GL_LINE_STIPPLE’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:552: error: ‘glDisable’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
‘virtual void kiva::gl_graphics_context::draw_rect(double*,
kiva::draw_mode_e)’:
enthought/kiva/agg/src/gl_graphics_context.cpp:570: error:
‘GL_LINE_SMOOTH’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:570: error: ‘glEnable’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:571: error:
‘GL_POLYGON_SMOOTH’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:575: error:
‘GL_LINE_SMOOTH’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:575: error: ‘glDisable’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:576: error:
‘GL_POLYGON_SMOOTH’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:584: error: ‘glColor4f’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:585: error: ‘glRectf’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:592: error: ‘glColor4f’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:593: error:
‘glLineWidth’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:597: error:
‘GL_LINE_STIPPLE’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:597: error: ‘glDisable’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:601: error:
‘GL_LINE_STIPPLE’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:601: error: ‘glDisable’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:604: error:
‘GL_LINE_LOOP’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:604: error: ‘glBegin’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:605: error:
‘glVertex2f’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:609: error: ‘glEnd’ was
not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
‘virtual int kiva::gl_graphics_context::draw_marker_at_points(double*,
int, int, agg::marker_e)’:
enthought/kiva/agg/src/gl_graphics_context.cpp:624: error:
‘glLineWidth’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:638: error: ‘GLuint’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:638: error: expected
‘;’ before ‘fill_list’
enthought/kiva/agg/src/gl_graphics_context.cpp:669: error: ‘fill_list’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:669: error:
‘make_marker_lists’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:685: error:
‘stroke_list’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:687: error:
‘glDeleteLists’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp: At global scope:
enthought/kiva/agg/src/gl_graphics_context.cpp:726: error: variable or
field ‘draw_display_list_at_pts’ declared void
enthought/kiva/agg/src/gl_graphics_context.cpp:726: error: ‘GLuint’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:726: error: expected
primary-expression before ‘double’
enthought/kiva/agg/src/gl_graphics_context.cpp:726: error: expected
primary-expression before ‘int’
enthought/kiva/agg/src/gl_graphics_context.cpp:727: error: expected
primary-expression before ‘mode’
enthought/kiva/agg/src/gl_graphics_context.cpp:727: error: expected
primary-expression before ‘double’
enthought/kiva/agg/src/gl_graphics_context.cpp:727: error: expected
primary-expression before ‘double’
enthought/kiva/agg/src/gl_graphics_context.cpp:732: error: variable or
field ‘draw_display_list_at_pts’ declared void
enthought/kiva/agg/src/gl_graphics_context.cpp:732: error: ‘GLuint’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:732: error: ‘GLuint’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:733: error: expected
primary-expression before ‘double’
enthought/kiva/agg/src/gl_graphics_context.cpp:733: error: expected
primary-expression before ‘int’
enthought/kiva/agg/src/gl_graphics_context.cpp:734: error: expected
primary-expression before ‘mode’
enthought/kiva/agg/src/gl_graphics_context.cpp:734: error: expected
primary-expression before ‘double’
enthought/kiva/agg/src/gl_graphics_context.cpp:734: error: expected
primary-expression before ‘double’
In file included from enthought/kiva/agg/src/gl_graphics_context.cpp:13:
enthought/kiva/agg/src/gl_graphics_context.h:15:20: error: GL/gl.h: No
such file or directory
enthought/kiva/agg/src/gl_graphics_context.h:16:21: error: GL/glu.h:
No such file or directory
In file included from enthought/kiva/agg/src/gl_graphics_context.cpp:13:
enthought/kiva/agg/src/gl_graphics_context.h:111: error: ‘GLuint’ has
not been declared
enthought/kiva/agg/src/gl_graphics_context.h:113: error: ‘GLuint’ has
not been declared
enthought/kiva/agg/src/gl_graphics_context.h:113: error: ‘GLuint’ has
not been declared
enthought/kiva/agg/src/gl_graphics_context.h:122: error: ‘GLuint’ does
not name a type
enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
‘void kiva::gl_graphics_context::gl_init()’:
enthought/kiva/agg/src/gl_graphics_context.cpp:43: error: ‘glViewport’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:44: error:
‘GL_PROJECTION’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:44: error:
‘glMatrixMode’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:45: error:
‘glLoadIdentity’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:46: error: ‘glOrtho’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:47: error:
‘GL_MODELVIEW’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:52: error:
‘GL_SCISSOR_TEST’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:52: error: ‘glEnable’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:55: error: ‘GL_BLEND’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:56: error:
‘GL_SRC_ALPHA’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:56: error:
‘GL_ONE_MINUS_SRC_ALPHA’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:56: error:
‘glBlendFunc’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:57: error:
‘GL_LINE_SMOOTH_HINT’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:57: error:
‘GL_DONT_CARE’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:57: error: ‘glHint’ was
not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:58: error:
‘GL_POLYGON_SMOOTH_HINT’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:64: error: ‘glScissor’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
‘void kiva::gl_graphics_context::save_state()’:
enthought/kiva/agg/src/gl_graphics_context.cpp:83: error:
‘GL_MODELVIEW’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:83: error:
‘glMatrixMode’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:84: error:
‘glPushMatrix’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
‘virtual void kiva::gl_graphics_context::restore_state()’:
enthought/kiva/agg/src/gl_graphics_context.cpp:113: error: ‘glScissor’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:122: error:
‘GL_MODELVIEW’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:122: error:
‘glMatrixMode’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:123: error:
‘glPopMatrix’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
‘void kiva::gl_graphics_context::begin_page()’:
enthought/kiva/agg/src/gl_graphics_context.cpp:129: error:
‘glClearColor’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:130: error:
‘GL_COLOR_BUFFER_BIT’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:130: error: ‘glClear’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
‘virtual void kiva::gl_graphics_context::clip_to_rect(kiva::rect_type&)’:
enthought/kiva/agg/src/gl_graphics_context.cpp:167: error: ‘glScissor’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:174: error: ‘glScissor’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:188: error: ‘glScissor’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:199: error: ‘glScissor’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
‘virtual void kiva::gl_graphics_context::clear_clip_path()’:
enthought/kiva/agg/src/gl_graphics_context.cpp:225: error: ‘glScissor’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
‘virtual void kiva::gl_graphics_context::clear(agg::rgba)’:
enthought/kiva/agg/src/gl_graphics_context.cpp:280: error:
‘glClearColor’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:281: error:
‘GL_COLOR_BUFFER_BIT’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:281: error: ‘glClear’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
‘void kiva::gl_graphics_context::gl_render_path(kiva::compiled_path*,
bool, bool)’:
enthought/kiva/agg/src/gl_graphics_context.cpp:316: error:
‘GL_MODELVIEW’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:316: error:
‘glMatrixMode’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:324: error:
‘GL_POLYGON’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:324: error: ‘glBegin’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:332: error:
‘GL_LINE_LOOP’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:332: error: ‘glBegin’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:338: error:
‘GL_LINE_STRIP’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:338: error: ‘glBegin’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:348: error: ‘GLfloat’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:348: error: expected
‘;’ before ‘vvx’
enthought/kiva/agg/src/gl_graphics_context.cpp:364: error: expected
‘)’ before ‘x0’
enthought/kiva/agg/src/gl_graphics_context.cpp:364: error: expected
‘)’ before ‘y0’
enthought/kiva/agg/src/gl_graphics_context.cpp:364: error:
‘glVertex2f’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:367: error: expected
‘)’ before ‘vx’
enthought/kiva/agg/src/gl_graphics_context.cpp:367: error: expected
‘)’ before ‘vy’
enthought/kiva/agg/src/gl_graphics_context.cpp:367: error:
‘glVertex2f’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:381: error: expected
‘)’ before ‘x0’
enthought/kiva/agg/src/gl_graphics_context.cpp:381: error: expected
‘)’ before ‘y0’
enthought/kiva/agg/src/gl_graphics_context.cpp:398: error: ‘vvx’ was
not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:399: error: ‘vvy’ was
not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:407: error: expected
‘)’ before ‘x0’
enthought/kiva/agg/src/gl_graphics_context.cpp:407: error: expected
‘)’ before ‘y0’
enthought/kiva/agg/src/gl_graphics_context.cpp:421: error: ‘vvx’ was
not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:422: error: ‘vvy’ was
not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:429: error: ‘glEnd’ was
not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:433: error:
‘GL_POLYGON’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:433: error: ‘glBegin’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:435: error:
‘GL_LINE_LOOP’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:435: error: ‘glBegin’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:439: error:
‘GL_LINE_STRIP’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:439: error: ‘glBegin’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:462: error: ‘glEnd’ was
not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
‘virtual void kiva::gl_graphics_context::draw_path(kiva::draw_mode_e)’:
enthought/kiva/agg/src/gl_graphics_context.cpp:485: error:
‘GL_LINE_SMOOTH’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:485: error: ‘glEnable’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:486: error:
‘GL_POLYGON_SMOOTH’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:490: error:
‘GL_LINE_SMOOTH’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:490: error: ‘glDisable’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:491: error:
‘GL_POLYGON_SMOOTH’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:531: error: ‘glColor4f’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:543: error: ‘glColor4f’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:544: error:
‘glLineWidth’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:548: error:
‘GL_LINE_STIPPLE’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:548: error: ‘glDisable’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:552: error:
‘GL_LINE_STIPPLE’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:552: error: ‘glDisable’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
‘virtual void kiva::gl_graphics_context::draw_rect(double*,
kiva::draw_mode_e)’:
enthought/kiva/agg/src/gl_graphics_context.cpp:570: error:
‘GL_LINE_SMOOTH’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:570: error: ‘glEnable’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:571: error:
‘GL_POLYGON_SMOOTH’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:575: error:
‘GL_LINE_SMOOTH’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:575: error: ‘glDisable’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:576: error:
‘GL_POLYGON_SMOOTH’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:584: error: ‘glColor4f’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:585: error: ‘glRectf’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:592: error: ‘glColor4f’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:593: error:
‘glLineWidth’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:597: error:
‘GL_LINE_STIPPLE’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:597: error: ‘glDisable’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:601: error:
‘GL_LINE_STIPPLE’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:601: error: ‘glDisable’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:604: error:
‘GL_LINE_LOOP’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:604: error: ‘glBegin’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:605: error:
‘glVertex2f’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:609: error: ‘glEnd’ was
not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
‘virtual int kiva::gl_graphics_context::draw_marker_at_points(double*,
int, int, agg::marker_e)’:
enthought/kiva/agg/src/gl_graphics_context.cpp:624: error:
‘glLineWidth’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:638: error: ‘GLuint’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:638: error: expected
‘;’ before ‘fill_list’
enthought/kiva/agg/src/gl_graphics_context.cpp:669: error: ‘fill_list’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:669: error:
‘make_marker_lists’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:685: error:
‘stroke_list’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:687: error:
‘glDeleteLists’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp: At global scope:
enthought/kiva/agg/src/gl_graphics_context.cpp:726: error: variable or
field ‘draw_display_list_at_pts’ declared void
enthought/kiva/agg/src/gl_graphics_context.cpp:726: error: ‘GLuint’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:726: error: expected
primary-expression before ‘double’
enthought/kiva/agg/src/gl_graphics_context.cpp:726: error: expected
primary-expression before ‘int’
enthought/kiva/agg/src/gl_graphics_context.cpp:727: error: expected
primary-expression before ‘mode’
enthought/kiva/agg/src/gl_graphics_context.cpp:727: error: expected
primary-expression before ‘double’
enthought/kiva/agg/src/gl_graphics_context.cpp:727: error: expected
primary-expression before ‘double’
enthought/kiva/agg/src/gl_graphics_context.cpp:732: error: variable or
field ‘draw_display_list_at_pts’ declared void
enthought/kiva/agg/src/gl_graphics_context.cpp:732: error: ‘GLuint’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:732: error: ‘GLuint’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:733: error: expected
primary-expression before ‘double’
enthought/kiva/agg/src/gl_graphics_context.cpp:733: error: expected
primary-expression before ‘int’
enthought/kiva/agg/src/gl_graphics_context.cpp:734: error: expected
primary-expression before ‘mode’
enthought/kiva/agg/src/gl_graphics_context.cpp:734: error: expected
primary-expression before ‘double’
enthought/kiva/agg/src/gl_graphics_context.cpp:734: error: expected
primary-expression before ‘double’
error: Setup script exited with error: Command "g++ -pthread
-fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall -fPIC
-Ienthought/kiva/agg/src -Ienthought/kiva/agg/agg-24/include
-Ienthought/kiva/agg/agg-24/font_freetype
-Ienthought/kiva/agg/freetype2/src/autofit
-Ienthought/kiva/agg/freetype2/src/base
-Ienthought/kiva/agg/freetype2/src/bdf
-Ienthought/kiva/agg/freetype2/src/cache
-Ienthought/kiva/agg/freetype2/src/cff
-Ienthought/kiva/agg/freetype2/src/cid
-Ienthought/kiva/agg/freetype2/src/gxvalid
-Ienthought/kiva/agg/freetype2/src/gzip
-Ienthought/kiva/agg/freetype2/src/lzw
-Ienthought/kiva/agg/freetype2/src/otvalid
-Ienthought/kiva/agg/freetype2/src/pcf
-Ienthought/kiva/agg/freetype2/src/pfr
-Ienthought/kiva/agg/freetype2/src/psaux
-Ienthought/kiva/agg/freetype2/src/pshinter
-Ienthought/kiva/agg/freetype2/src/psnames
-Ienthought/kiva/agg/freetype2/src/raster
-Ienthought/kiva/agg/freetype2/src/sfnt
-Ienthought/kiva/agg/freetype2/src/smooth
-Ienthought/kiva/agg/freetype2/src/tools
-Ienthought/kiva/agg/freetype2/src/truetype
-Ienthought/kiva/agg/freetype2/src/type1
-Ienthought/kiva/agg/freetype2/src/type42
-Ienthought/kiva/agg/freetype2/src/winfonts
-Ienthought/kiva/agg/freetype2/src/gzip
-Ienthought/kiva/agg/freetype2/include
-Ienthought/kiva/agg/freetype2/src
-I/usr/lib/python2.6/dist-packages/numpy/core/include -c
enthought/kiva/agg/src/gl_graphics_context.cpp -o
build/temp.linux-i686-2.6/enthought/kiva/agg/src/gl_graphics_context.o"
failed with exit status 1
$
_______________________________________________
Enthought-Dev mailing list
[hidden email]
https://mail.enthought.com/mailman/listinfo/enthought-dev
Reply | Threaded
Open this post in threaded view
|

Re: easy_install help on Ubuntu Karmic, Please?

Christoph Willing

On 11/04/2010, at 10:49 PM, Jerzy Jalocha N wrote:

>>> $ sudo easy_install Chaco[nonets]
> [...]
>>> error: Setup script exited with error: SandboxViolation:
>>> open('/tmp/easy_install-R1KuK1/Chaco-3.3.0/build/docs/html/_images/
>>> bar_plot.png',
>>> 'wb') {}
>>>
>>> The package setup script has attempted to modify files on your  
>>> system
>>> that are not within the EasyInstall build area, and has been  
>>> aborted.
>>>
>>> This package cannot be safely installed by EasyInstall, and may not
>>> support alternate installation locations even if you run its setup
>>> script by hand.  Please inform the package's author and the  
>>> EasyInstall
>>> maintainers to find out if a fix or workaround is available.
>>
>> This is a known issue, but it is difficult to replicate and track
>> down. Usually, you can just try again, and it will work (thus the
>> problem with replicating it).
>
> OK, I ran easy_install some more times, and I installed the missing
> 'python-pyrex' package (using the --without-recommends option, in
> order to avoid installing 'python-all' and 'python-all-dev').
>
> I also installed 'python-xlib', but It still complains about missing
> X11 libraries.


 From another thread, here is a list of packages I had to install on  
Karmic to build a complete ETS installation from svn recently.  
Although you're only doing Chaco, I'd guess the list is pretty close  
to what you need. If you use apt-get to install them, you'll end up  
with whole bunch of additional prerequisites e.g. the "sudo apt-get  
install libxtst-dev" command will install many X11 libraries in  
addition to libxtst-dev files.

Although I was using ETSProjectTools to do the work, rather than  
easy_tools directly, the prerequisites will be the same.

Heres the list:
sudo apt-get install python-dev
sudo apt-get install libxtst-dev
sudo apt-get install swig
sudo apt-get install scons
sudo apt-get install python-numpy-dev
sudo apt-get install python-vtk
sudo apt-get install pyqt4-dev-tools
sudo apt-get install python2.6-wxgtk2.8
sudo apt-get install python-configobj


chris


> When I repeat the easy_install command now, I always get exactly the
> same error output.
>
>
> $ sudo easy_install Chaco[nonets]
> Searching for Chaco[nonets]
> Best match: Chaco 3.3.0
> Processing Chaco-3.3.0-py2.6-linux-i686.egg
> Chaco 3.3.0 is already the active version in easy-install.pth
>
> Using /usr/local/lib/python2.6/dist-packages/Chaco-3.3.0-py2.6-linux-
> i686.egg
> Processing dependencies for Chaco[nonets]
> Searching for Enable[traits]>=3.3.0.dev
> Reading http://pypi.python.org/simple/Enable/
> Reading http://code.enthought.com/projects/enable
> Best match: Enable 3.3.0
> Downloading http://enthought.com/repo/ets/Enable-3.3.0.tar.gz
> Processing Enable-3.3.0.tar.gz
> Running Enable-3.3.0/setup.py -q bdist_egg --dist-dir
> /tmp/easy_install-YsSgGI/Enable-3.3.0/egg-dist-tmp-tM1xb9
> /usr/lib/python2.6/dist-packages/numpy/distutils/system_info.py:452:
> UserWarning: X11 libraries not found.
>  warnings.warn(self.notfounderror.__doc__)
> package init file './enthought/savage/traits/ui/wx/data/__init__.py'
> not found (or not a regular file)
> package init file './enthought/savage/traits/ui/wx/data/__init__.py'
> not found (or not a regular file)
> package init file './enthought/savage/traits/ui/wx/data/__init__.py'
> not found (or not a regular file)
> enthought/kiva/agg/agg-24/src/agg_curves.cpp:245: warning: ‘double
> agg::MSC60_fix_ICE(double)’ defined but not used
> enthought/kiva/agg/agg-24/include/agg_trans_double_path.h: In
> constructor ‘agg::trans_double_path::trans_double_path()’:
> enthought/kiva/agg/agg-24/include/agg_trans_double_path.h:122:
> warning: ‘agg::trans_double_path::m_kindex2’ will be initialized after
> enthought/kiva/agg/agg-24/include/agg_trans_double_path.h:119:
> warning:   ‘double agg::trans_double_path::m_base_length’
> enthought/kiva/agg/agg-24/src/agg_trans_double_path.cpp:23: warning:
> when initialized here
> enthought/kiva/agg/agg-24/src/agg_gsv_text.cpp: In member function
> ‘void agg::gsv_text::load_font(const char*)’:
> enthought/kiva/agg/agg-24/src/agg_gsv_text.cpp:559: warning: ignoring
> return value of ‘size_t fread(void*, size_t, size_t, FILE*)’, declared
> with attribute warn_unused_result
> enthought/kiva/agg/src/kiva_hit_test.cpp: In function ‘bool
> kiva::toggle_odd_node(double, double, double, double, double,
> double)’:
> enthought/kiva/agg/src/kiva_hit_test.cpp:27: warning: suggest
> parentheses around ‘&&’ within ‘||’
> In file included from enthought/kiva/agg/src/gl_graphics_context.cpp:
> 13:
> enthought/kiva/agg/src/gl_graphics_context.h:15:20: error: GL/gl.h: No
> such file or directory
> enthought/kiva/agg/src/gl_graphics_context.h:16:21: error: GL/glu.h:
> No such file or directory
> In file included from enthought/kiva/agg/src/gl_graphics_context.cpp:
> 13:
> enthought/kiva/agg/src/gl_graphics_context.h:111: error: ‘GLuint’ has
> not been declared
> enthought/kiva/agg/src/gl_graphics_context.h:113: error: ‘GLuint’ has
> not been declared
> enthought/kiva/agg/src/gl_graphics_context.h:113: error: ‘GLuint’ has
> not been declared
> enthought/kiva/agg/src/gl_graphics_context.h:122: error: ‘GLuint’ does
> not name a type
> enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
> ‘void kiva::gl_graphics_context::gl_init()’:
> enthought/kiva/agg/src/gl_graphics_context.cpp:43: error: ‘glViewport’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:44: error:
> ‘GL_PROJECTION’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:44: error:
> ‘glMatrixMode’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:45: error:
> ‘glLoadIdentity’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:46: error: ‘glOrtho’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:47: error:
> ‘GL_MODELVIEW’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:52: error:
> ‘GL_SCISSOR_TEST’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:52: error: ‘glEnable’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:55: error: ‘GL_BLEND’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:56: error:
> ‘GL_SRC_ALPHA’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:56: error:
> ‘GL_ONE_MINUS_SRC_ALPHA’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:56: error:
> ‘glBlendFunc’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:57: error:
> ‘GL_LINE_SMOOTH_HINT’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:57: error:
> ‘GL_DONT_CARE’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:57: error: ‘glHint’ was
> not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:58: error:
> ‘GL_POLYGON_SMOOTH_HINT’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:64: error: ‘glScissor’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
> ‘void kiva::gl_graphics_context::save_state()’:
> enthought/kiva/agg/src/gl_graphics_context.cpp:83: error:
> ‘GL_MODELVIEW’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:83: error:
> ‘glMatrixMode’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:84: error:
> ‘glPushMatrix’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
> ‘virtual void kiva::gl_graphics_context::restore_state()’:
> enthought/kiva/agg/src/gl_graphics_context.cpp:113: error: ‘glScissor’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:122: error:
> ‘GL_MODELVIEW’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:122: error:
> ‘glMatrixMode’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:123: error:
> ‘glPopMatrix’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
> ‘void kiva::gl_graphics_context::begin_page()’:
> enthought/kiva/agg/src/gl_graphics_context.cpp:129: error:
> ‘glClearColor’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:130: error:
> ‘GL_COLOR_BUFFER_BIT’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:130: error: ‘glClear’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
> ‘virtual void  
> kiva::gl_graphics_context::clip_to_rect(kiva::rect_type&)’:
> enthought/kiva/agg/src/gl_graphics_context.cpp:167: error: ‘glScissor’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:174: error: ‘glScissor’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:188: error: ‘glScissor’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:199: error: ‘glScissor’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
> ‘virtual void kiva::gl_graphics_context::clear_clip_path()’:
> enthought/kiva/agg/src/gl_graphics_context.cpp:225: error: ‘glScissor’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
> ‘virtual void kiva::gl_graphics_context::clear(agg::rgba)’:
> enthought/kiva/agg/src/gl_graphics_context.cpp:280: error:
> ‘glClearColor’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:281: error:
> ‘GL_COLOR_BUFFER_BIT’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:281: error: ‘glClear’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
> ‘void kiva::gl_graphics_context::gl_render_path(kiva::compiled_path*,
> bool, bool)’:
> enthought/kiva/agg/src/gl_graphics_context.cpp:316: error:
> ‘GL_MODELVIEW’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:316: error:
> ‘glMatrixMode’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:324: error:
> ‘GL_POLYGON’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:324: error: ‘glBegin’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:332: error:
> ‘GL_LINE_LOOP’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:332: error: ‘glBegin’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:338: error:
> ‘GL_LINE_STRIP’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:338: error: ‘glBegin’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:348: error: ‘GLfloat’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:348: error: expected
> ‘;’ before ‘vvx’
> enthought/kiva/agg/src/gl_graphics_context.cpp:364: error: expected
> ‘)’ before ‘x0’
> enthought/kiva/agg/src/gl_graphics_context.cpp:364: error: expected
> ‘)’ before ‘y0’
> enthought/kiva/agg/src/gl_graphics_context.cpp:364: error:
> ‘glVertex2f’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:367: error: expected
> ‘)’ before ‘vx’
> enthought/kiva/agg/src/gl_graphics_context.cpp:367: error: expected
> ‘)’ before ‘vy’
> enthought/kiva/agg/src/gl_graphics_context.cpp:367: error:
> ‘glVertex2f’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:381: error: expected
> ‘)’ before ‘x0’
> enthought/kiva/agg/src/gl_graphics_context.cpp:381: error: expected
> ‘)’ before ‘y0’
> enthought/kiva/agg/src/gl_graphics_context.cpp:398: error: ‘vvx’ was
> not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:399: error: ‘vvy’ was
> not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:407: error: expected
> ‘)’ before ‘x0’
> enthought/kiva/agg/src/gl_graphics_context.cpp:407: error: expected
> ‘)’ before ‘y0’
> enthought/kiva/agg/src/gl_graphics_context.cpp:421: error: ‘vvx’ was
> not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:422: error: ‘vvy’ was
> not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:429: error: ‘glEnd’ was
> not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:433: error:
> ‘GL_POLYGON’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:433: error: ‘glBegin’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:435: error:
> ‘GL_LINE_LOOP’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:435: error: ‘glBegin’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:439: error:
> ‘GL_LINE_STRIP’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:439: error: ‘glBegin’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:462: error: ‘glEnd’ was
> not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
> ‘virtual void  
> kiva::gl_graphics_context::draw_path(kiva::draw_mode_e)’:
> enthought/kiva/agg/src/gl_graphics_context.cpp:485: error:
> ‘GL_LINE_SMOOTH’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:485: error: ‘glEnable’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:486: error:
> ‘GL_POLYGON_SMOOTH’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:490: error:
> ‘GL_LINE_SMOOTH’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:490: error: ‘glDisable’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:491: error:
> ‘GL_POLYGON_SMOOTH’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:531: error: ‘glColor4f’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:543: error: ‘glColor4f’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:544: error:
> ‘glLineWidth’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:548: error:
> ‘GL_LINE_STIPPLE’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:548: error: ‘glDisable’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:552: error:
> ‘GL_LINE_STIPPLE’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:552: error: ‘glDisable’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
> ‘virtual void kiva::gl_graphics_context::draw_rect(double*,
> kiva::draw_mode_e)’:
> enthought/kiva/agg/src/gl_graphics_context.cpp:570: error:
> ‘GL_LINE_SMOOTH’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:570: error: ‘glEnable’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:571: error:
> ‘GL_POLYGON_SMOOTH’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:575: error:
> ‘GL_LINE_SMOOTH’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:575: error: ‘glDisable’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:576: error:
> ‘GL_POLYGON_SMOOTH’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:584: error: ‘glColor4f’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:585: error: ‘glRectf’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:592: error: ‘glColor4f’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:593: error:
> ‘glLineWidth’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:597: error:
> ‘GL_LINE_STIPPLE’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:597: error: ‘glDisable’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:601: error:
> ‘GL_LINE_STIPPLE’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:601: error: ‘glDisable’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:604: error:
> ‘GL_LINE_LOOP’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:604: error: ‘glBegin’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:605: error:
> ‘glVertex2f’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:609: error: ‘glEnd’ was
> not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
> ‘virtual int kiva::gl_graphics_context::draw_marker_at_points(double*,
> int, int, agg::marker_e)’:
> enthought/kiva/agg/src/gl_graphics_context.cpp:624: error:
> ‘glLineWidth’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:638: error: ‘GLuint’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:638: error: expected
> ‘;’ before ‘fill_list’
> enthought/kiva/agg/src/gl_graphics_context.cpp:669: error: ‘fill_list’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:669: error:
> ‘make_marker_lists’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:685: error:
> ‘stroke_list’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:687: error:
> ‘glDeleteLists’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp: At global scope:
> enthought/kiva/agg/src/gl_graphics_context.cpp:726: error: variable or
> field ‘draw_display_list_at_pts’ declared void
> enthought/kiva/agg/src/gl_graphics_context.cpp:726: error: ‘GLuint’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:726: error: expected
> primary-expression before ‘double’
> enthought/kiva/agg/src/gl_graphics_context.cpp:726: error: expected
> primary-expression before ‘int’
> enthought/kiva/agg/src/gl_graphics_context.cpp:727: error: expected
> primary-expression before ‘mode’
> enthought/kiva/agg/src/gl_graphics_context.cpp:727: error: expected
> primary-expression before ‘double’
> enthought/kiva/agg/src/gl_graphics_context.cpp:727: error: expected
> primary-expression before ‘double’
> enthought/kiva/agg/src/gl_graphics_context.cpp:732: error: variable or
> field ‘draw_display_list_at_pts’ declared void
> enthought/kiva/agg/src/gl_graphics_context.cpp:732: error: ‘GLuint’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:732: error: ‘GLuint’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:733: error: expected
> primary-expression before ‘double’
> enthought/kiva/agg/src/gl_graphics_context.cpp:733: error: expected
> primary-expression before ‘int’
> enthought/kiva/agg/src/gl_graphics_context.cpp:734: error: expected
> primary-expression before ‘mode’
> enthought/kiva/agg/src/gl_graphics_context.cpp:734: error: expected
> primary-expression before ‘double’
> enthought/kiva/agg/src/gl_graphics_context.cpp:734: error: expected
> primary-expression before ‘double’
> In file included from enthought/kiva/agg/src/gl_graphics_context.cpp:
> 13:
> enthought/kiva/agg/src/gl_graphics_context.h:15:20: error: GL/gl.h: No
> such file or directory
> enthought/kiva/agg/src/gl_graphics_context.h:16:21: error: GL/glu.h:
> No such file or directory
> In file included from enthought/kiva/agg/src/gl_graphics_context.cpp:
> 13:
> enthought/kiva/agg/src/gl_graphics_context.h:111: error: ‘GLuint’ has
> not been declared
> enthought/kiva/agg/src/gl_graphics_context.h:113: error: ‘GLuint’ has
> not been declared
> enthought/kiva/agg/src/gl_graphics_context.h:113: error: ‘GLuint’ has
> not been declared
> enthought/kiva/agg/src/gl_graphics_context.h:122: error: ‘GLuint’ does
> not name a type
> enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
> ‘void kiva::gl_graphics_context::gl_init()’:
> enthought/kiva/agg/src/gl_graphics_context.cpp:43: error: ‘glViewport’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:44: error:
> ‘GL_PROJECTION’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:44: error:
> ‘glMatrixMode’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:45: error:
> ‘glLoadIdentity’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:46: error: ‘glOrtho’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:47: error:
> ‘GL_MODELVIEW’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:52: error:
> ‘GL_SCISSOR_TEST’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:52: error: ‘glEnable’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:55: error: ‘GL_BLEND’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:56: error:
> ‘GL_SRC_ALPHA’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:56: error:
> ‘GL_ONE_MINUS_SRC_ALPHA’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:56: error:
> ‘glBlendFunc’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:57: error:
> ‘GL_LINE_SMOOTH_HINT’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:57: error:
> ‘GL_DONT_CARE’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:57: error: ‘glHint’ was
> not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:58: error:
> ‘GL_POLYGON_SMOOTH_HINT’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:64: error: ‘glScissor’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
> ‘void kiva::gl_graphics_context::save_state()’:
> enthought/kiva/agg/src/gl_graphics_context.cpp:83: error:
> ‘GL_MODELVIEW’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:83: error:
> ‘glMatrixMode’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:84: error:
> ‘glPushMatrix’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
> ‘virtual void kiva::gl_graphics_context::restore_state()’:
> enthought/kiva/agg/src/gl_graphics_context.cpp:113: error: ‘glScissor’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:122: error:
> ‘GL_MODELVIEW’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:122: error:
> ‘glMatrixMode’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:123: error:
> ‘glPopMatrix’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
> ‘void kiva::gl_graphics_context::begin_page()’:
> enthought/kiva/agg/src/gl_graphics_context.cpp:129: error:
> ‘glClearColor’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:130: error:
> ‘GL_COLOR_BUFFER_BIT’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:130: error: ‘glClear’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
> ‘virtual void  
> kiva::gl_graphics_context::clip_to_rect(kiva::rect_type&)’:
> enthought/kiva/agg/src/gl_graphics_context.cpp:167: error: ‘glScissor’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:174: error: ‘glScissor’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:188: error: ‘glScissor’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:199: error: ‘glScissor’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
> ‘virtual void kiva::gl_graphics_context::clear_clip_path()’:
> enthought/kiva/agg/src/gl_graphics_context.cpp:225: error: ‘glScissor’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
> ‘virtual void kiva::gl_graphics_context::clear(agg::rgba)’:
> enthought/kiva/agg/src/gl_graphics_context.cpp:280: error:
> ‘glClearColor’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:281: error:
> ‘GL_COLOR_BUFFER_BIT’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:281: error: ‘glClear’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
> ‘void kiva::gl_graphics_context::gl_render_path(kiva::compiled_path*,
> bool, bool)’:
> enthought/kiva/agg/src/gl_graphics_context.cpp:316: error:
> ‘GL_MODELVIEW’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:316: error:
> ‘glMatrixMode’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:324: error:
> ‘GL_POLYGON’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:324: error: ‘glBegin’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:332: error:
> ‘GL_LINE_LOOP’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:332: error: ‘glBegin’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:338: error:
> ‘GL_LINE_STRIP’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:338: error: ‘glBegin’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:348: error: ‘GLfloat’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:348: error: expected
> ‘;’ before ‘vvx’
> enthought/kiva/agg/src/gl_graphics_context.cpp:364: error: expected
> ‘)’ before ‘x0’
> enthought/kiva/agg/src/gl_graphics_context.cpp:364: error: expected
> ‘)’ before ‘y0’
> enthought/kiva/agg/src/gl_graphics_context.cpp:364: error:
> ‘glVertex2f’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:367: error: expected
> ‘)’ before ‘vx’
> enthought/kiva/agg/src/gl_graphics_context.cpp:367: error: expected
> ‘)’ before ‘vy’
> enthought/kiva/agg/src/gl_graphics_context.cpp:367: error:
> ‘glVertex2f’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:381: error: expected
> ‘)’ before ‘x0’
> enthought/kiva/agg/src/gl_graphics_context.cpp:381: error: expected
> ‘)’ before ‘y0’
> enthought/kiva/agg/src/gl_graphics_context.cpp:398: error: ‘vvx’ was
> not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:399: error: ‘vvy’ was
> not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:407: error: expected
> ‘)’ before ‘x0’
> enthought/kiva/agg/src/gl_graphics_context.cpp:407: error: expected
> ‘)’ before ‘y0’
> enthought/kiva/agg/src/gl_graphics_context.cpp:421: error: ‘vvx’ was
> not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:422: error: ‘vvy’ was
> not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:429: error: ‘glEnd’ was
> not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:433: error:
> ‘GL_POLYGON’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:433: error: ‘glBegin’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:435: error:
> ‘GL_LINE_LOOP’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:435: error: ‘glBegin’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:439: error:
> ‘GL_LINE_STRIP’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:439: error: ‘glBegin’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:462: error: ‘glEnd’ was
> not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
> ‘virtual void  
> kiva::gl_graphics_context::draw_path(kiva::draw_mode_e)’:
> enthought/kiva/agg/src/gl_graphics_context.cpp:485: error:
> ‘GL_LINE_SMOOTH’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:485: error: ‘glEnable’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:486: error:
> ‘GL_POLYGON_SMOOTH’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:490: error:
> ‘GL_LINE_SMOOTH’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:490: error: ‘glDisable’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:491: error:
> ‘GL_POLYGON_SMOOTH’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:531: error: ‘glColor4f’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:543: error: ‘glColor4f’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:544: error:
> ‘glLineWidth’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:548: error:
> ‘GL_LINE_STIPPLE’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:548: error: ‘glDisable’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:552: error:
> ‘GL_LINE_STIPPLE’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:552: error: ‘glDisable’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
> ‘virtual void kiva::gl_graphics_context::draw_rect(double*,
> kiva::draw_mode_e)’:
> enthought/kiva/agg/src/gl_graphics_context.cpp:570: error:
> ‘GL_LINE_SMOOTH’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:570: error: ‘glEnable’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:571: error:
> ‘GL_POLYGON_SMOOTH’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:575: error:
> ‘GL_LINE_SMOOTH’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:575: error: ‘glDisable’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:576: error:
> ‘GL_POLYGON_SMOOTH’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:584: error: ‘glColor4f’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:585: error: ‘glRectf’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:592: error: ‘glColor4f’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:593: error:
> ‘glLineWidth’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:597: error:
> ‘GL_LINE_STIPPLE’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:597: error: ‘glDisable’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:601: error:
> ‘GL_LINE_STIPPLE’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:601: error: ‘glDisable’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:604: error:
> ‘GL_LINE_LOOP’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:604: error: ‘glBegin’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:605: error:
> ‘glVertex2f’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:609: error: ‘glEnd’ was
> not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
> ‘virtual int kiva::gl_graphics_context::draw_marker_at_points(double*,
> int, int, agg::marker_e)’:
> enthought/kiva/agg/src/gl_graphics_context.cpp:624: error:
> ‘glLineWidth’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:638: error: ‘GLuint’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:638: error: expected
> ‘;’ before ‘fill_list’
> enthought/kiva/agg/src/gl_graphics_context.cpp:669: error: ‘fill_list’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:669: error:
> ‘make_marker_lists’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:685: error:
> ‘stroke_list’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:687: error:
> ‘glDeleteLists’ was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp: At global scope:
> enthought/kiva/agg/src/gl_graphics_context.cpp:726: error: variable or
> field ‘draw_display_list_at_pts’ declared void
> enthought/kiva/agg/src/gl_graphics_context.cpp:726: error: ‘GLuint’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:726: error: expected
> primary-expression before ‘double’
> enthought/kiva/agg/src/gl_graphics_context.cpp:726: error: expected
> primary-expression before ‘int’
> enthought/kiva/agg/src/gl_graphics_context.cpp:727: error: expected
> primary-expression before ‘mode’
> enthought/kiva/agg/src/gl_graphics_context.cpp:727: error: expected
> primary-expression before ‘double’
> enthought/kiva/agg/src/gl_graphics_context.cpp:727: error: expected
> primary-expression before ‘double’
> enthought/kiva/agg/src/gl_graphics_context.cpp:732: error: variable or
> field ‘draw_display_list_at_pts’ declared void
> enthought/kiva/agg/src/gl_graphics_context.cpp:732: error: ‘GLuint’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:732: error: ‘GLuint’
> was not declared in this scope
> enthought/kiva/agg/src/gl_graphics_context.cpp:733: error: expected
> primary-expression before ‘double’
> enthought/kiva/agg/src/gl_graphics_context.cpp:733: error: expected
> primary-expression before ‘int’
> enthought/kiva/agg/src/gl_graphics_context.cpp:734: error: expected
> primary-expression before ‘mode’
> enthought/kiva/agg/src/gl_graphics_context.cpp:734: error: expected
> primary-expression before ‘double’
> enthought/kiva/agg/src/gl_graphics_context.cpp:734: error: expected
> primary-expression before ‘double’
> error: Setup script exited with error: Command "g++ -pthread
> -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall -fPIC
> -Ienthought/kiva/agg/src -Ienthought/kiva/agg/agg-24/include
> -Ienthought/kiva/agg/agg-24/font_freetype
> -Ienthought/kiva/agg/freetype2/src/autofit
> -Ienthought/kiva/agg/freetype2/src/base
> -Ienthought/kiva/agg/freetype2/src/bdf
> -Ienthought/kiva/agg/freetype2/src/cache
> -Ienthought/kiva/agg/freetype2/src/cff
> -Ienthought/kiva/agg/freetype2/src/cid
> -Ienthought/kiva/agg/freetype2/src/gxvalid
> -Ienthought/kiva/agg/freetype2/src/gzip
> -Ienthought/kiva/agg/freetype2/src/lzw
> -Ienthought/kiva/agg/freetype2/src/otvalid
> -Ienthought/kiva/agg/freetype2/src/pcf
> -Ienthought/kiva/agg/freetype2/src/pfr
> -Ienthought/kiva/agg/freetype2/src/psaux
> -Ienthought/kiva/agg/freetype2/src/pshinter
> -Ienthought/kiva/agg/freetype2/src/psnames
> -Ienthought/kiva/agg/freetype2/src/raster
> -Ienthought/kiva/agg/freetype2/src/sfnt
> -Ienthought/kiva/agg/freetype2/src/smooth
> -Ienthought/kiva/agg/freetype2/src/tools
> -Ienthought/kiva/agg/freetype2/src/truetype
> -Ienthought/kiva/agg/freetype2/src/type1
> -Ienthought/kiva/agg/freetype2/src/type42
> -Ienthought/kiva/agg/freetype2/src/winfonts
> -Ienthought/kiva/agg/freetype2/src/gzip
> -Ienthought/kiva/agg/freetype2/include
> -Ienthought/kiva/agg/freetype2/src
> -I/usr/lib/python2.6/dist-packages/numpy/core/include -c
> enthought/kiva/agg/src/gl_graphics_context.cpp -o
> build/temp.linux-i686-2.6/enthought/kiva/agg/src/
> gl_graphics_context.o"
> failed with exit status 1
> $
> _______________________________________________
> Enthought-Dev mailing list
> [hidden email]
> https://mail.enthought.com/mailman/listinfo/enthought-dev

Christoph Willing                       +61 7 3365 8316
QCIF Access Grid Manager
University of Queensland

_______________________________________________
Enthought-Dev mailing list
[hidden email]
https://mail.enthought.com/mailman/listinfo/enthought-dev
Reply | Threaded
Open this post in threaded view
|

Re: easy_install help on Ubuntu Karmic, Please?

Jerzy Jalocha N
>  From another thread, here is a list of packages I had to install on
> Karmic to build a complete ETS installation from svn recently.
> Although you're only doing Chaco, I'd guess the list is pretty close
> to what you need. If you use apt-get to install them, you'll end up
> with whole bunch of additional prerequisites e.g. the "sudo apt-get
> install libxtst-dev" command will install many X11 libraries in
> addition to libxtst-dev files.
>
> Although I was using ETSProjectTools to do the work, rather than
> easy_tools directly, the prerequisites will be the same.
>
> Heres the list:
> sudo apt-get install python-dev
> sudo apt-get install libxtst-dev
> sudo apt-get install swig
> sudo apt-get install scons
> sudo apt-get install python-numpy-dev
> sudo apt-get install python-vtk
> sudo apt-get install pyqt4-dev-tools
> sudo apt-get install python2.6-wxgtk2.8
> sudo apt-get install python-configobj

Thanks, Christoph, for your answer. I am sorry, I missed that thread
in my search. Sadly, It still gets stuck after installing all the
packages. I will try to find out what is missing now.

These are the packages I installed manually. Of course, there are many
more that got pulled in automatically as dependencies.

 * python-setuptools
 * libxtst-dev
 * python-configobj
 * python-dev
 * python-numpy-dev
 * python-pyrex        (--without-recommends)
 * python-scipy
 * python-vtk
 * python-wxgtk2.8
 * python-xlib
 * pyqt4-dev-tools
 * scons
 * swig

And this is the output I get now for Chaco. (It gets stuck with ETS, too):

$ sudo easy_install Chaco[nonets]
Searching for Chaco[nonets]
Best match: Chaco 3.3.0
Processing Chaco-3.3.0-py2.6-linux-i686.egg
Chaco 3.3.0 is already the active version in easy-install.pth

Using /usr/local/lib/python2.6/dist-packages/Chaco-3.3.0-py2.6-linux-i686.egg
Processing dependencies for Chaco[nonets]
Searching for Enable[traits]>=3.3.0.dev
Reading http://pypi.python.org/simple/Enable/
Reading http://code.enthought.com/projects/enable
Best match: Enable 3.3.0
Downloading http://enthought.com/repo/ets/Enable-3.3.0.tar.gz
Processing Enable-3.3.0.tar.gz
Running Enable-3.3.0/setup.py -q bdist_egg --dist-dir
/tmp/easy_install-FJ2lXA/Enable-3.3.0/egg-dist-tmp-iX43Fc
package init file './enthought/savage/traits/ui/wx/data/__init__.py'
not found (or not a regular file)
package init file './enthought/savage/traits/ui/wx/data/__init__.py'
not found (or not a regular file)
package init file './enthought/savage/traits/ui/wx/data/__init__.py'
not found (or not a regular file)
enthought/kiva/agg/agg-24/src/agg_curves.cpp:245: warning: ‘double
agg::MSC60_fix_ICE(double)’ defined but not used
enthought/kiva/agg/agg-24/include/agg_trans_double_path.h: In
constructor ‘agg::trans_double_path::trans_double_path()’:
enthought/kiva/agg/agg-24/include/agg_trans_double_path.h:122:
warning: ‘agg::trans_double_path::m_kindex2’ will be initialized after
enthought/kiva/agg/agg-24/include/agg_trans_double_path.h:119:
warning:   ‘double agg::trans_double_path::m_base_length’
enthought/kiva/agg/agg-24/src/agg_trans_double_path.cpp:23: warning:
when initialized here
enthought/kiva/agg/agg-24/src/agg_gsv_text.cpp: In member function
‘void agg::gsv_text::load_font(const char*)’:
enthought/kiva/agg/agg-24/src/agg_gsv_text.cpp:559: warning: ignoring
return value of ‘size_t fread(void*, size_t, size_t, FILE*)’, declared
with attribute warn_unused_result
enthought/kiva/agg/src/kiva_hit_test.cpp: In function ‘bool
kiva::toggle_odd_node(double, double, double, double, double,
double)’:
enthought/kiva/agg/src/kiva_hit_test.cpp:27: warning: suggest
parentheses around ‘&&’ within ‘||’
In file included from enthought/kiva/agg/src/gl_graphics_context.cpp:13:
enthought/kiva/agg/src/gl_graphics_context.h:15:20: error: GL/gl.h: No
such file or directory
enthought/kiva/agg/src/gl_graphics_context.h:16:21: error: GL/glu.h:
No such file or directory
In file included from enthought/kiva/agg/src/gl_graphics_context.cpp:13:
enthought/kiva/agg/src/gl_graphics_context.h:111: error: ‘GLuint’ has
not been declared
enthought/kiva/agg/src/gl_graphics_context.h:113: error: ‘GLuint’ has
not been declared
enthought/kiva/agg/src/gl_graphics_context.h:113: error: ‘GLuint’ has
not been declared
enthought/kiva/agg/src/gl_graphics_context.h:122: error: ‘GLuint’ does
not name a type
enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
‘void kiva::gl_graphics_context::gl_init()’:
enthought/kiva/agg/src/gl_graphics_context.cpp:43: error: ‘glViewport’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:44: error:
‘GL_PROJECTION’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:44: error:
‘glMatrixMode’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:45: error:
‘glLoadIdentity’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:46: error: ‘glOrtho’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:47: error:
‘GL_MODELVIEW’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:52: error:
‘GL_SCISSOR_TEST’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:52: error: ‘glEnable’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:55: error: ‘GL_BLEND’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:56: error:
‘GL_SRC_ALPHA’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:56: error:
‘GL_ONE_MINUS_SRC_ALPHA’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:56: error:
‘glBlendFunc’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:57: error:
‘GL_LINE_SMOOTH_HINT’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:57: error:
‘GL_DONT_CARE’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:57: error: ‘glHint’ was
not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:58: error:
‘GL_POLYGON_SMOOTH_HINT’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:64: error: ‘glScissor’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
‘void kiva::gl_graphics_context::save_state()’:
enthought/kiva/agg/src/gl_graphics_context.cpp:83: error:
‘GL_MODELVIEW’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:83: error:
‘glMatrixMode’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:84: error:
‘glPushMatrix’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
‘virtual void kiva::gl_graphics_context::restore_state()’:
enthought/kiva/agg/src/gl_graphics_context.cpp:113: error: ‘glScissor’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:122: error:
‘GL_MODELVIEW’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:122: error:
‘glMatrixMode’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:123: error:
‘glPopMatrix’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
‘void kiva::gl_graphics_context::begin_page()’:
enthought/kiva/agg/src/gl_graphics_context.cpp:129: error:
‘glClearColor’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:130: error:
‘GL_COLOR_BUFFER_BIT’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:130: error: ‘glClear’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
‘virtual void kiva::gl_graphics_context::clip_to_rect(kiva::rect_type&)’:
enthought/kiva/agg/src/gl_graphics_context.cpp:167: error: ‘glScissor’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:174: error: ‘glScissor’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:188: error: ‘glScissor’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:199: error: ‘glScissor’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
‘virtual void kiva::gl_graphics_context::clear_clip_path()’:
enthought/kiva/agg/src/gl_graphics_context.cpp:225: error: ‘glScissor’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
‘virtual void kiva::gl_graphics_context::clear(agg::rgba)’:
enthought/kiva/agg/src/gl_graphics_context.cpp:280: error:
‘glClearColor’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:281: error:
‘GL_COLOR_BUFFER_BIT’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:281: error: ‘glClear’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
‘void kiva::gl_graphics_context::gl_render_path(kiva::compiled_path*,
bool, bool)’:
enthought/kiva/agg/src/gl_graphics_context.cpp:316: error:
‘GL_MODELVIEW’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:316: error:
‘glMatrixMode’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:324: error:
‘GL_POLYGON’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:324: error: ‘glBegin’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:332: error:
‘GL_LINE_LOOP’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:332: error: ‘glBegin’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:338: error:
‘GL_LINE_STRIP’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:338: error: ‘glBegin’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:348: error: ‘GLfloat’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:348: error: expected
‘;’ before ‘vvx’
enthought/kiva/agg/src/gl_graphics_context.cpp:364: error: expected
‘)’ before ‘x0’
enthought/kiva/agg/src/gl_graphics_context.cpp:364: error: expected
‘)’ before ‘y0’
enthought/kiva/agg/src/gl_graphics_context.cpp:364: error:
‘glVertex2f’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:367: error: expected
‘)’ before ‘vx’
enthought/kiva/agg/src/gl_graphics_context.cpp:367: error: expected
‘)’ before ‘vy’
enthought/kiva/agg/src/gl_graphics_context.cpp:367: error:
‘glVertex2f’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:381: error: expected
‘)’ before ‘x0’
enthought/kiva/agg/src/gl_graphics_context.cpp:381: error: expected
‘)’ before ‘y0’
enthought/kiva/agg/src/gl_graphics_context.cpp:398: error: ‘vvx’ was
not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:399: error: ‘vvy’ was
not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:407: error: expected
‘)’ before ‘x0’
enthought/kiva/agg/src/gl_graphics_context.cpp:407: error: expected
‘)’ before ‘y0’
enthought/kiva/agg/src/gl_graphics_context.cpp:421: error: ‘vvx’ was
not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:422: error: ‘vvy’ was
not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:429: error: ‘glEnd’ was
not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:433: error:
‘GL_POLYGON’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:433: error: ‘glBegin’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:435: error:
‘GL_LINE_LOOP’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:435: error: ‘glBegin’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:439: error:
‘GL_LINE_STRIP’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:439: error: ‘glBegin’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:462: error: ‘glEnd’ was
not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
‘virtual void kiva::gl_graphics_context::draw_path(kiva::draw_mode_e)’:
enthought/kiva/agg/src/gl_graphics_context.cpp:485: error:
‘GL_LINE_SMOOTH’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:485: error: ‘glEnable’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:486: error:
‘GL_POLYGON_SMOOTH’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:490: error:
‘GL_LINE_SMOOTH’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:490: error: ‘glDisable’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:491: error:
‘GL_POLYGON_SMOOTH’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:531: error: ‘glColor4f’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:543: error: ‘glColor4f’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:544: error:
‘glLineWidth’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:548: error:
‘GL_LINE_STIPPLE’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:548: error: ‘glDisable’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:552: error:
‘GL_LINE_STIPPLE’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:552: error: ‘glDisable’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
‘virtual void kiva::gl_graphics_context::draw_rect(double*,
kiva::draw_mode_e)’:
enthought/kiva/agg/src/gl_graphics_context.cpp:570: error:
‘GL_LINE_SMOOTH’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:570: error: ‘glEnable’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:571: error:
‘GL_POLYGON_SMOOTH’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:575: error:
‘GL_LINE_SMOOTH’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:575: error: ‘glDisable’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:576: error:
‘GL_POLYGON_SMOOTH’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:584: error: ‘glColor4f’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:585: error: ‘glRectf’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:592: error: ‘glColor4f’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:593: error:
‘glLineWidth’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:597: error:
‘GL_LINE_STIPPLE’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:597: error: ‘glDisable’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:601: error:
‘GL_LINE_STIPPLE’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:601: error: ‘glDisable’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:604: error:
‘GL_LINE_LOOP’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:604: error: ‘glBegin’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:605: error:
‘glVertex2f’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:609: error: ‘glEnd’ was
not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
‘virtual int kiva::gl_graphics_context::draw_marker_at_points(double*,
int, int, agg::marker_e)’:
enthought/kiva/agg/src/gl_graphics_context.cpp:624: error:
‘glLineWidth’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:638: error: ‘GLuint’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:638: error: expected
‘;’ before ‘fill_list’
enthought/kiva/agg/src/gl_graphics_context.cpp:669: error: ‘fill_list’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:669: error:
‘make_marker_lists’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:685: error:
‘stroke_list’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:687: error:
‘glDeleteLists’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp: At global scope:
enthought/kiva/agg/src/gl_graphics_context.cpp:726: error: variable or
field ‘draw_display_list_at_pts’ declared void
enthought/kiva/agg/src/gl_graphics_context.cpp:726: error: ‘GLuint’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:726: error: expected
primary-expression before ‘double’
enthought/kiva/agg/src/gl_graphics_context.cpp:726: error: expected
primary-expression before ‘int’
enthought/kiva/agg/src/gl_graphics_context.cpp:727: error: expected
primary-expression before ‘mode’
enthought/kiva/agg/src/gl_graphics_context.cpp:727: error: expected
primary-expression before ‘double’
enthought/kiva/agg/src/gl_graphics_context.cpp:727: error: expected
primary-expression before ‘double’
enthought/kiva/agg/src/gl_graphics_context.cpp:732: error: variable or
field ‘draw_display_list_at_pts’ declared void
enthought/kiva/agg/src/gl_graphics_context.cpp:732: error: ‘GLuint’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:732: error: ‘GLuint’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:733: error: expected
primary-expression before ‘double’
enthought/kiva/agg/src/gl_graphics_context.cpp:733: error: expected
primary-expression before ‘int’
enthought/kiva/agg/src/gl_graphics_context.cpp:734: error: expected
primary-expression before ‘mode’
enthought/kiva/agg/src/gl_graphics_context.cpp:734: error: expected
primary-expression before ‘double’
enthought/kiva/agg/src/gl_graphics_context.cpp:734: error: expected
primary-expression before ‘double’
In file included from enthought/kiva/agg/src/gl_graphics_context.cpp:13:
enthought/kiva/agg/src/gl_graphics_context.h:15:20: error: GL/gl.h: No
such file or directory
enthought/kiva/agg/src/gl_graphics_context.h:16:21: error: GL/glu.h:
No such file or directory
In file included from enthought/kiva/agg/src/gl_graphics_context.cpp:13:
enthought/kiva/agg/src/gl_graphics_context.h:111: error: ‘GLuint’ has
not been declared
enthought/kiva/agg/src/gl_graphics_context.h:113: error: ‘GLuint’ has
not been declared
enthought/kiva/agg/src/gl_graphics_context.h:113: error: ‘GLuint’ has
not been declared
enthought/kiva/agg/src/gl_graphics_context.h:122: error: ‘GLuint’ does
not name a type
enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
‘void kiva::gl_graphics_context::gl_init()’:
enthought/kiva/agg/src/gl_graphics_context.cpp:43: error: ‘glViewport’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:44: error:
‘GL_PROJECTION’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:44: error:
‘glMatrixMode’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:45: error:
‘glLoadIdentity’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:46: error: ‘glOrtho’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:47: error:
‘GL_MODELVIEW’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:52: error:
‘GL_SCISSOR_TEST’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:52: error: ‘glEnable’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:55: error: ‘GL_BLEND’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:56: error:
‘GL_SRC_ALPHA’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:56: error:
‘GL_ONE_MINUS_SRC_ALPHA’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:56: error:
‘glBlendFunc’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:57: error:
‘GL_LINE_SMOOTH_HINT’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:57: error:
‘GL_DONT_CARE’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:57: error: ‘glHint’ was
not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:58: error:
‘GL_POLYGON_SMOOTH_HINT’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:64: error: ‘glScissor’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
‘void kiva::gl_graphics_context::save_state()’:
enthought/kiva/agg/src/gl_graphics_context.cpp:83: error:
‘GL_MODELVIEW’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:83: error:
‘glMatrixMode’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:84: error:
‘glPushMatrix’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
‘virtual void kiva::gl_graphics_context::restore_state()’:
enthought/kiva/agg/src/gl_graphics_context.cpp:113: error: ‘glScissor’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:122: error:
‘GL_MODELVIEW’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:122: error:
‘glMatrixMode’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:123: error:
‘glPopMatrix’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
‘void kiva::gl_graphics_context::begin_page()’:
enthought/kiva/agg/src/gl_graphics_context.cpp:129: error:
‘glClearColor’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:130: error:
‘GL_COLOR_BUFFER_BIT’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:130: error: ‘glClear’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
‘virtual void kiva::gl_graphics_context::clip_to_rect(kiva::rect_type&)’:
enthought/kiva/agg/src/gl_graphics_context.cpp:167: error: ‘glScissor’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:174: error: ‘glScissor’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:188: error: ‘glScissor’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:199: error: ‘glScissor’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
‘virtual void kiva::gl_graphics_context::clear_clip_path()’:
enthought/kiva/agg/src/gl_graphics_context.cpp:225: error: ‘glScissor’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
‘virtual void kiva::gl_graphics_context::clear(agg::rgba)’:
enthought/kiva/agg/src/gl_graphics_context.cpp:280: error:
‘glClearColor’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:281: error:
‘GL_COLOR_BUFFER_BIT’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:281: error: ‘glClear’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
‘void kiva::gl_graphics_context::gl_render_path(kiva::compiled_path*,
bool, bool)’:
enthought/kiva/agg/src/gl_graphics_context.cpp:316: error:
‘GL_MODELVIEW’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:316: error:
‘glMatrixMode’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:324: error:
‘GL_POLYGON’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:324: error: ‘glBegin’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:332: error:
‘GL_LINE_LOOP’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:332: error: ‘glBegin’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:338: error:
‘GL_LINE_STRIP’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:338: error: ‘glBegin’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:348: error: ‘GLfloat’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:348: error: expected
‘;’ before ‘vvx’
enthought/kiva/agg/src/gl_graphics_context.cpp:364: error: expected
‘)’ before ‘x0’
enthought/kiva/agg/src/gl_graphics_context.cpp:364: error: expected
‘)’ before ‘y0’
enthought/kiva/agg/src/gl_graphics_context.cpp:364: error:
‘glVertex2f’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:367: error: expected
‘)’ before ‘vx’
enthought/kiva/agg/src/gl_graphics_context.cpp:367: error: expected
‘)’ before ‘vy’
enthought/kiva/agg/src/gl_graphics_context.cpp:367: error:
‘glVertex2f’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:381: error: expected
‘)’ before ‘x0’
enthought/kiva/agg/src/gl_graphics_context.cpp:381: error: expected
‘)’ before ‘y0’
enthought/kiva/agg/src/gl_graphics_context.cpp:398: error: ‘vvx’ was
not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:399: error: ‘vvy’ was
not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:407: error: expected
‘)’ before ‘x0’
enthought/kiva/agg/src/gl_graphics_context.cpp:407: error: expected
‘)’ before ‘y0’
enthought/kiva/agg/src/gl_graphics_context.cpp:421: error: ‘vvx’ was
not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:422: error: ‘vvy’ was
not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:429: error: ‘glEnd’ was
not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:433: error:
‘GL_POLYGON’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:433: error: ‘glBegin’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:435: error:
‘GL_LINE_LOOP’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:435: error: ‘glBegin’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:439: error:
‘GL_LINE_STRIP’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:439: error: ‘glBegin’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:462: error: ‘glEnd’ was
not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
‘virtual void kiva::gl_graphics_context::draw_path(kiva::draw_mode_e)’:
enthought/kiva/agg/src/gl_graphics_context.cpp:485: error:
‘GL_LINE_SMOOTH’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:485: error: ‘glEnable’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:486: error:
‘GL_POLYGON_SMOOTH’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:490: error:
‘GL_LINE_SMOOTH’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:490: error: ‘glDisable’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:491: error:
‘GL_POLYGON_SMOOTH’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:531: error: ‘glColor4f’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:543: error: ‘glColor4f’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:544: error:
‘glLineWidth’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:548: error:
‘GL_LINE_STIPPLE’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:548: error: ‘glDisable’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:552: error:
‘GL_LINE_STIPPLE’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:552: error: ‘glDisable’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
‘virtual void kiva::gl_graphics_context::draw_rect(double*,
kiva::draw_mode_e)’:
enthought/kiva/agg/src/gl_graphics_context.cpp:570: error:
‘GL_LINE_SMOOTH’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:570: error: ‘glEnable’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:571: error:
‘GL_POLYGON_SMOOTH’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:575: error:
‘GL_LINE_SMOOTH’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:575: error: ‘glDisable’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:576: error:
‘GL_POLYGON_SMOOTH’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:584: error: ‘glColor4f’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:585: error: ‘glRectf’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:592: error: ‘glColor4f’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:593: error:
‘glLineWidth’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:597: error:
‘GL_LINE_STIPPLE’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:597: error: ‘glDisable’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:601: error:
‘GL_LINE_STIPPLE’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:601: error: ‘glDisable’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:604: error:
‘GL_LINE_LOOP’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:604: error: ‘glBegin’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:605: error:
‘glVertex2f’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:609: error: ‘glEnd’ was
not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp: In member function
‘virtual int kiva::gl_graphics_context::draw_marker_at_points(double*,
int, int, agg::marker_e)’:
enthought/kiva/agg/src/gl_graphics_context.cpp:624: error:
‘glLineWidth’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:638: error: ‘GLuint’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:638: error: expected
‘;’ before ‘fill_list’
enthought/kiva/agg/src/gl_graphics_context.cpp:669: error: ‘fill_list’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:669: error:
‘make_marker_lists’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:685: error:
‘stroke_list’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:687: error:
‘glDeleteLists’ was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp: At global scope:
enthought/kiva/agg/src/gl_graphics_context.cpp:726: error: variable or
field ‘draw_display_list_at_pts’ declared void
enthought/kiva/agg/src/gl_graphics_context.cpp:726: error: ‘GLuint’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:726: error: expected
primary-expression before ‘double’
enthought/kiva/agg/src/gl_graphics_context.cpp:726: error: expected
primary-expression before ‘int’
enthought/kiva/agg/src/gl_graphics_context.cpp:727: error: expected
primary-expression before ‘mode’
enthought/kiva/agg/src/gl_graphics_context.cpp:727: error: expected
primary-expression before ‘double’
enthought/kiva/agg/src/gl_graphics_context.cpp:727: error: expected
primary-expression before ‘double’
enthought/kiva/agg/src/gl_graphics_context.cpp:732: error: variable or
field ‘draw_display_list_at_pts’ declared void
enthought/kiva/agg/src/gl_graphics_context.cpp:732: error: ‘GLuint’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:732: error: ‘GLuint’
was not declared in this scope
enthought/kiva/agg/src/gl_graphics_context.cpp:733: error: expected
primary-expression before ‘double’
enthought/kiva/agg/src/gl_graphics_context.cpp:733: error: expected
primary-expression before ‘int’
enthought/kiva/agg/src/gl_graphics_context.cpp:734: error: expected
primary-expression before ‘mode’
enthought/kiva/agg/src/gl_graphics_context.cpp:734: error: expected
primary-expression before ‘double’
enthought/kiva/agg/src/gl_graphics_context.cpp:734: error: expected
primary-expression before ‘double’
error: Setup script exited with error: Command "g++ -pthread
-fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall -fPIC
-Ienthought/kiva/agg/src -Ienthought/kiva/agg/agg-24/include
-Ienthought/kiva/agg/agg-24/font_freetype
-Ienthought/kiva/agg/freetype2/src/autofit
-Ienthought/kiva/agg/freetype2/src/base
-Ienthought/kiva/agg/freetype2/src/bdf
-Ienthought/kiva/agg/freetype2/src/cache
-Ienthought/kiva/agg/freetype2/src/cff
-Ienthought/kiva/agg/freetype2/src/cid
-Ienthought/kiva/agg/freetype2/src/gxvalid
-Ienthought/kiva/agg/freetype2/src/gzip
-Ienthought/kiva/agg/freetype2/src/lzw
-Ienthought/kiva/agg/freetype2/src/otvalid
-Ienthought/kiva/agg/freetype2/src/pcf
-Ienthought/kiva/agg/freetype2/src/pfr
-Ienthought/kiva/agg/freetype2/src/psaux
-Ienthought/kiva/agg/freetype2/src/pshinter
-Ienthought/kiva/agg/freetype2/src/psnames
-Ienthought/kiva/agg/freetype2/src/raster
-Ienthought/kiva/agg/freetype2/src/sfnt
-Ienthought/kiva/agg/freetype2/src/smooth
-Ienthought/kiva/agg/freetype2/src/tools
-Ienthought/kiva/agg/freetype2/src/truetype
-Ienthought/kiva/agg/freetype2/src/type1
-Ienthought/kiva/agg/freetype2/src/type42
-Ienthought/kiva/agg/freetype2/src/winfonts
-Ienthought/kiva/agg/freetype2/src/gzip
-Ienthought/kiva/agg/freetype2/include
-Ienthought/kiva/agg/freetype2/src
-I/usr/lib/python2.6/dist-packages/numpy/core/include -c
enthought/kiva/agg/src/gl_graphics_context.cpp -o
build/temp.linux-i686-2.6/enthought/kiva/agg/src/gl_graphics_context.o"
failed with exit status 1
$
_______________________________________________
Enthought-Dev mailing list
[hidden email]
https://mail.enthought.com/mailman/listinfo/enthought-dev
Reply | Threaded
Open this post in threaded view
|

Re: easy_install help on Ubuntu Karmic, Please?

Peter Wang
Jerry, your problem is this:

On Sun, Apr 11, 2010 at 2:09 PM, Jerzy Jalocha N <[hidden email]> wrote:
> enthought/kiva/agg/src/gl_graphics_context.h:15:20: error: GL/gl.h: No
> such file or directory

You don't have the OpenGL headers installed.  Install either
mesa-common-dev, or if you have an Nvidia card, you can install
nvidia-glx-dev.

-Peter
_______________________________________________
Enthought-Dev mailing list
[hidden email]
https://mail.enthought.com/mailman/listinfo/enthought-dev
Reply | Threaded
Open this post in threaded view
|

Re: easy_install help on Ubuntu Karmic, Please?

Jerzy Jalocha N
> Jerry, your problem is this:
>
>> enthought/kiva/agg/src/gl_graphics_context.h:15:20: error: GL/gl.h: No
>> such file or directory
>
> You don't have the OpenGL headers installed.  Install either
> mesa-common-dev, or if you have an Nvidia card, you can install
> nvidia-glx-dev.

Thank you, Peter, for the pointer.

But even after installing 'mesa-common-dev' and 'libglu1-mesa-dev',
the error still persists:

$ sudo easy_install Chaco[nonets]
[...]
Running Enable-3.3.0/setup.py -q bdist_egg --dist-dir
/tmp/easy_install-C9dN2W/Enable-3.3.0/egg-dist-tmp-5rc9Ho
package init file './enthought/savage/traits/ui/wx/data/__init__.py'
not found (or not a regular file)
package init file './enthought/savage/traits/ui/wx/data/__init__.py'
not found (or not a regular file)
package init file './enthought/savage/traits/ui/wx/data/__init__.py'
not found (or not a regular file)
[...]
In file included from enthought/kiva/agg/src/gl_graphics_context.cpp:13:
enthought/kiva/agg/src/gl_graphics_context.h:16:21: error: GL/glu.h:
No such file or directory
In file included from enthought/kiva/agg/src/gl_graphics_context.cpp:13:
enthought/kiva/agg/src/gl_graphics_context.h:16:21: error: GL/glu.h:
No such file or directory
[...]


And ETS fails, too:

$ sudo easy_install ETS[nonets]
[...]
Running BlockCanvas-3.1.1/setup.py -q bdist_egg --dist-dir
/tmp/easy_install-c3Izqd/BlockCanvas-3.1.1/egg-dist-tmp-a5MxXA
error: Setup script exited with error:
/tmp/easy_install-cgTvZf/CodeTools-3.1.1/docs/html.zip: No such file
or directory
_______________________________________________
Enthought-Dev mailing list
[hidden email]
https://mail.enthought.com/mailman/listinfo/enthought-dev
Reply | Threaded
Open this post in threaded view
|

Re: easy_install help on Ubuntu Karmic, Please?

Peter Wang
On Sun, Apr 11, 2010 at 6:32 PM, Jerzy Jalocha N <[hidden email]> wrote:

>> Jerry, your problem is this:
>>
>>> enthought/kiva/agg/src/gl_graphics_context.h:15:20: error: GL/gl.h: No
>>> such file or directory
>>
>> You don't have the OpenGL headers installed.  Install either
>> mesa-common-dev, or if you have an Nvidia card, you can install
>> nvidia-glx-dev.
>
> Thank you, Peter, for the pointer.
>
> But even after installing 'mesa-common-dev' and 'libglu1-mesa-dev',
> the error still persists:

Ah, you also need libglu1-mesa-dev.  Sorry for not pointing this out earlier.

Not sure what's going on with the ETS error...

-Peter
_______________________________________________
Enthought-Dev mailing list
[hidden email]
https://mail.enthought.com/mailman/listinfo/enthought-dev
Reply | Threaded
Open this post in threaded view
|

Re: easy_install help on Ubuntu Karmic, Please?

Jerzy Jalocha N
>> But even after installing 'mesa-common-dev' and 'libglu1-mesa-dev',
>> the error still persists:
>
> Ah, you also need libglu1-mesa-dev.  Sorry for not pointing this out earlier.
>
> Not sure what's going on with the ETS error...

It's very strange, Peter, but as you can see, I had already installed
libglu1-mesa-dev (I found that dependency on another thread), and the
error still persists.

>In file included from enthought/kiva/agg/src/gl_graphics_context.cpp:13:
>enthought/kiva/agg/src/gl_graphics_context.h:16:21: error: GL/glu.h:
>No such file or directory

I will keep searching for a solution.
_______________________________________________
Enthought-Dev mailing list
[hidden email]
https://mail.enthought.com/mailman/listinfo/enthought-dev
Reply | Threaded
Open this post in threaded view
|

Re: easy_install help on Ubuntu Karmic, Please?

Peter Wang
On Mon, Apr 12, 2010 at 10:02 AM, Jerzy Jalocha N <[hidden email]> wrote:
>>> But even after installing 'mesa-common-dev' and 'libglu1-mesa-dev',
>>> the error still persists:
...
> I will keep searching for a solution.

Do you mind telling me the path to your GL/glu.h file?

Thanks,
Peter
_______________________________________________
Enthought-Dev mailing list
[hidden email]
https://mail.enthought.com/mailman/listinfo/enthought-dev
Reply | Threaded
Open this post in threaded view
|

Re: easy_install help on Ubuntu Karmic, Please?

Jerzy Jalocha N
>>>> But even after installing 'mesa-common-dev' and 'libglu1-mesa-dev',
>>>> the error still persists:
>
> Do you mind telling me the path to your GL/glu.h file?

Peter, the GL header files are installed in Ubuntu under
/usr/include/GL. The contents of this directory is:
 gl.h
 gl_mangle.h
 glext.h
 glu.h
 glu_mangle.h
 glx.h
 glx_mangle.h
 glxext.h
 internal

Here is a link to the complete filelist of the Ubuntu package:
http://packages.ubuntu.com/karmic/i386/libglu1-mesa-dev/filelist

Thank you very much, Peter, for all the time you are spending on this
issue, helping me!
_______________________________________________
Enthought-Dev mailing list
[hidden email]
https://mail.enthought.com/mailman/listinfo/enthought-dev
Reply | Threaded
Open this post in threaded view
|

Re: easy_install help on Ubuntu Karmic, Please?

Peter Wang
On Mon, Apr 12, 2010 at 3:44 PM, Jerzy Jalocha N <[hidden email]> wrote:
> Peter, the GL header files are installed in Ubuntu under
> /usr/include/GL.

OK... gcc should be able to pick this up by default, regardless of
what our setup.py's command line switches say.  Can you attach the
full text of the build output, up to and including the line
"enthought/kiva/agg/src/gl_graphics_context.h:16:21: error: GL/glu.h"?
 I don't need to see any of the errors after it, but I do want to see
the exact output that leads up to it.

> Thank you very much, Peter, for all the time you are spending on this
> issue, helping me!

No problem, thanks for your patience in working through this!

-Peter
_______________________________________________
Enthought-Dev mailing list
[hidden email]
https://mail.enthought.com/mailman/listinfo/enthought-dev
Reply | Threaded
Open this post in threaded view
|

Re: easy_install help on Ubuntu Karmic, Please?

Jerzy Jalocha N
>> Peter, the GL header files are installed in Ubuntu under
>> /usr/include/GL.
>
> OK... gcc should be able to pick this up by default, regardless of
> what our setup.py's command line switches say.  Can you attach the
> full text of the build output, up to and including the line
> "enthought/kiva/agg/src/gl_graphics_context.h:16:21: error: GL/glu.h"?
>  I don't need to see any of the errors after it, but I do want to see
> the exact output that leads up to it.

I attached the complete command-line output, since there's only one
single line after the error.

> No problem, thanks for your patience in working through this!

I really hope, that we can solve this, so that I and others can
benefit from Enthought, which looks really interesting, at least on
paper :P

_______________________________________________
Enthought-Dev mailing list
[hidden email]
https://mail.enthought.com/mailman/listinfo/enthought-dev

log-26_Chaco (5K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: easy_install help on Ubuntu Karmic, Please?

Peter Wang
On Mon, Apr 12, 2010 at 4:44 PM, Jerzy Jalocha N <[hidden email]> wrote:
> I attached the complete command-line output, since there's only one
> single line after the error.

Jerzy, this is pretty confusing for me, since I don't see why the
compiler would not pick up the GL headers if they are in /usr/include.
 Can you try checking out the source for Enable from SVN, and then
building it from the checkout directory?

$ svn co https://svn.enthought.com/svn/enthought/Enable/trunk Enable
$ cd Enable
$ python setup.py bdist_egg

This should produce an egg in your dist/ subdirectory.  If it doesn't,
please attach the build output.

Thanks,
Peter
_______________________________________________
Enthought-Dev mailing list
[hidden email]
https://mail.enthought.com/mailman/listinfo/enthought-dev
Reply | Threaded
Open this post in threaded view
|

Re: easy_install help on Ubuntu Karmic, Please?

Jerzy Jalocha N
> Jerzy, this is pretty confusing for me, since I don't see why the
> compiler would not pick up the GL headers if they are in /usr/include.
>  Can you try checking out the source for Enable from SVN, and then
> building it from the checkout directory?
>
> $ svn co https://svn.enthought.com/svn/enthought/Enable/trunk Enable
> $ cd Enable
> $ python setup.py bdist_egg
>
> This should produce an egg in your dist/ subdirectory.  If it doesn't,
> please attach the build output.
>

Peter, sorry for the delay. Just now I found the time for looking into this.

I downloaded the SVN revision 25473 (thanks for the instructions!),
and built it without problems. A
/dist/Enable-3.3.1.dev_r0-py2.6-linux-i686.egg file
 was created, and there are no errors on the command-line output.

Anything else I should try?

Cheers,

Jerzy
_______________________________________________
Enthought-Dev mailing list
[hidden email]
https://mail.enthought.com/mailman/listinfo/enthought-dev
Reply | Threaded
Open this post in threaded view
|

Re: easy_install help on Ubuntu Karmic, Please?

Peter Wang
On Wed, Apr 14, 2010 at 2:26 PM, Jerzy Jalocha N <[hidden email]> wrote:

>> Jerzy, this is pretty confusing for me, since I don't see why the
>> compiler would not pick up the GL headers if they are in /usr/include.
>>  Can you try checking out the source for Enable from SVN, and then
>> building it from the checkout directory?
>>
>> $ svn co https://svn.enthought.com/svn/enthought/Enable/trunk Enable
>> $ cd Enable
>> $ python setup.py bdist_egg
>
> Peter, sorry for the delay. Just now I found the time for looking into this.
>
> I downloaded the SVN revision 25473 (thanks for the instructions!),
> and built it without problems. A
> /dist/Enable-3.3.1.dev_r0-py2.6-linux-i686.egg file
>  was created, and there are no errors on the command-line output.

> Anything else I should try?

Uh... well, you could go into that directory, then run "easy_install
Enable-3.3.1.dev_r0-py2.6-linux-i686.egg", and then you'll have
Enable.  Do a similar thing for Chaco:

$ svn co https://svn.enthought.com/svn/enthought/Chaco/trunk Chaco
$ cd Chaco
$ python setup.py bdist_egg
$ easy_install dist/<EGG_NAME>

Run the Chaco examples in the examples/ subdirectory, and if those
work, then you're all set.

-Peter
_______________________________________________
Enthought-Dev mailing list
[hidden email]
https://mail.enthought.com/mailman/listinfo/enthought-dev
Reply | Threaded
Open this post in threaded view
|

Re: easy_install help on Ubuntu Karmic, Please?

Jerzy Jalocha N
Hi, everyone,
just for the record, I will post here how I finally managed to install
Chaco on Xubuntu 9.10 Karmic Koala, using easy_install. I hope, this
may help some other noobs out there.

I installed the following dependency packages:
 * python-setuptools
 * libglu1-mesa-dev
 * libxt-dev (I didn't install libxaw-headers)
 * libxtst-dev
 * python-configobj
 * python-dev
 * python-pyrex      (using the --without-recommends option)
 * python-scipy
 * python-vtk
 * python-wxgtk2.8
 * python-xlib
 * pyqt4-dev-tools
 * scons
 * swig
 * (mesa-common-dev got auto-installed)

In order to do a clean start, I removed all previous installation
attempts from '/usr/local/lib/python2.6/dist-packages/', which in my
case was every single file in that directory.

Then, I downloaded the latest versions for Traits, TraitsBackendWX and
Chaco from http://www.enthought.com/repo/ETS/, and installed in the
following order:

 $ sudo easy_install Traits[nonets]
 $ sudo easy_install TraitsBackendWX[nonets]
 $ sudo easy_install Chaco[nonets]

I kept repeating the easy_install commands on each step until there
were no more errors.

The examples were not installed during this process, but I downloaded
some examples from
http://code.enthought.com/projects/chaco/docs/html/annotated_examples.html,
and they ran perfectly!

Thanks everyone on this thread for the quick and useful answers! I
really appreciate all the help.

Best regards,

Jerzy Jalocha N
_______________________________________________
Enthought-Dev mailing list
[hidden email]
https://mail.enthought.com/mailman/listinfo/enthought-dev