NumPy1.4.1 is released, update for EPD?

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

NumPy1.4.1 is released, update for EPD?

Michael Aye
Hi Enthought team,

as Numpy1.4.1 has been released, do we get soon an update for the EPD?
Usually I am not asking or pushing for things I get for free (academic
license), but in these times I am suffering from an incompatibility
with KyngChaos' GDAL, that is still using Numpy1.3 and won't update to
Numpy1.4.0 as it was officially withdrawn.
Just a question for me to know if i still should invest time in how to
compile GDAL on my own, or if i can hope for a soon to come update for
EPD? KyngChaos is ready to upgrade any moment, I believe.

Best regards,
Michael


_______________________________________________
Enthought-Dev mailing list
[hidden email]
https://mail.enthought.com/mailman/listinfo/enthought-dev
Reply | Threaded
Open this post in threaded view
|

Re: NumPy1.4.1 is released, update for EPD?

Ilan Schnell
Hello Michael,

while numpy 1.4.1 does not suffer from the ABI incompatibility
problem anymore (which 1.4.0 did), it removed the datetime
type, and we don't want to exclude this feature in EPD.
The plan for numpy in EPD is to update to numpy 2.0, as soon
as it is out and stay on 1.4.0 in the meantime.
GDAL is a package we're looking into, as there have been
several requests by now.  But don't hold your breath, it might
take a while until GDAL is in EPD, and maybe we will only add
it to the (subscriber) repository of extra packages.
So for now, I would try to compile GDAL myself.

Regards   Ilan


On Apr 30, 2010, at 8:49 AM, K.-Michael Aye wrote:

> Hi Enthought team,
>
> as Numpy1.4.1 has been released, do we get soon an update for the EPD?
> Usually I am not asking or pushing for things I get for free (academic
> license), but in these times I am suffering from an incompatibility
> with KyngChaos' GDAL, that is still using Numpy1.3 and won't update to
> Numpy1.4.0 as it was officially withdrawn.
> Just a question for me to know if i still should invest time in how to
> compile GDAL on my own, or if i can hope for a soon to come update for
> EPD? KyngChaos is ready to upgrade any moment, I believe.
>
> Best regards,
> Michael
>
>
> _______________________________________________
> Enthought-Dev mailing list
> [hidden email]
> https://mail.enthought.com/mailman/listinfo/enthought-dev

_______________________________________________
Enthought-Dev mailing list
[hidden email]
https://mail.enthought.com/mailman/listinfo/enthought-dev