Errors opening IDLE, QtConsole, PyLab

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Errors opening IDLE, QtConsole, PyLab

Josh Dempster
I'm a new python user who has been struggling to get a working installation of matplotlib before I tried Enthought. I'm on a Mac 10.7.3 trying to run various modules after installing EPD 7.3-2 x86. When I try to run PyLab, I get an import error:

dlopen(/Library/Python/2.7/site-packages/matplotlib-1.2.x-py2.7-macosx-10.8-intel.egg/matplotlib/backends/_macosx.so, 2): Library not loaded: /System/Library/Frameworks/CoreText.framework/Versions/A/CoreText
  Referenced from: /Library/Python/2.7/site-packages/matplotlib-1.2.x-py2.7-macosx-10.8-intel.egg/matplotlib/backends/_macosx.so
  Reason: image not found

I get the same error running QtConsole. I checked, and CoreText.framework just doesn't exist in Frameworks. (I also get this error trying to import pyplots from matplotlib.)

IDLE won't start at all; it just opens X11.

I tried first using the 32 bit version of EPD and had the same issues before I uninstalled and tried the 64 bit version.
Reply | Threaded
Open this post in threaded view
|

Re: Errors opening IDLE, QtConsole, PyLab

Jonathan March
Josh,

Looks like the detritus from your previous installation is getting in the way of your new installation. 
Delete or rename any .pth files in /Library/Python/2.7/site-packages/ and see whether that fixes it.
When you type:
>>> import sys; print sys.path
there should be nothing listed from /Library/Python/

hth,
Jonathan

On Wed, Aug 15, 2012 at 2:22 PM, Josh Dempster <[hidden email]> wrote:
I'm a new python user who has been struggling to get a working installation
of matplotlib before I tried Enthought. I'm on a Mac 10.7.3 trying to run
various modules after installing EPD 7.3-2 x86. When I try to run PyLab, I
get an import error:

dlopen(/Library/Python/2.7/site-packages/matplotlib-1.2.x-py2.7-macosx-10.8-intel.egg/matplotlib/backends/_macosx.so,
2): Library not loaded:
/System/Library/Frameworks/CoreText.framework/Versions/A/CoreText
  Referenced from:
/Library/Python/2.7/site-packages/matplotlib-1.2.x-py2.7-macosx-10.8-intel.egg/matplotlib/backends/_macosx.so
  Reason: image not found

I get the same error running QtConsole. I checked, and CoreText.framework
just doesn't exist in Frameworks. (I also get this error trying to import
pyplots from matplotlib.)

IDLE won't start at all; it just opens X11.

I tried first using the 32 bit version of EPD and had the same issues before
I uninstalled and tried the 64 bit version.



--
View this message in context: http://enthought-dev.117412.n3.nabble.com/Errors-opening-IDLE-QtConsole-PyLab-tp4025509.html
Sent from the Enthought Dev mailing list archive at Nabble.com.
_______________________________________________
Enthought-Dev mailing list
[hidden email]
https://mail.enthought.com/mailman/listinfo/enthought-dev


_______________________________________________
Enthought-Dev mailing list
[hidden email]
https://mail.enthought.com/mailman/listinfo/enthought-dev
Reply | Threaded
Open this post in threaded view
|

Re: Errors opening IDLE, QtConsole, PyLab

Josh Dempster
Jonathan,

Thanks! That fixed the issues with the pylab and other modules. However, IDLE still won't start. Any ideas?

-Josh

On Wed, Aug 15, 2012 at 3:01 PM, Jonathan March [via Enthought Dev] <[hidden email]> wrote:
Josh,

Looks like the detritus from your previous installation is getting in the way of your new installation. 
Delete or rename any .pth files in /Library/Python/2.7/site-packages/ and see whether that fixes it.
When you type:
>>> import sys; print sys.path
there should be nothing listed from /Library/Python/

hth,
Jonathan

On Wed, Aug 15, 2012 at 2:22 PM, Josh Dempster <[hidden email]> wrote:
I'm a new python user who has been struggling to get a working installation
of matplotlib before I tried Enthought. I'm on a Mac 10.7.3 trying to run
various modules after installing EPD 7.3-2 x86. When I try to run PyLab, I
get an import error:

dlopen(/Library/Python/2.7/site-packages/matplotlib-1.2.x-py2.7-macosx-10.8-intel.egg/matplotlib/backends/_macosx.so,
2): Library not loaded:
/System/Library/Frameworks/CoreText.framework/Versions/A/CoreText
  Referenced from:
/Library/Python/2.7/site-packages/matplotlib-1.2.x-py2.7-macosx-10.8-intel.egg/matplotlib/backends/_macosx.so
  Reason: image not found

I get the same error running QtConsole. I checked, and CoreText.framework
just doesn't exist in Frameworks. (I also get this error trying to import
pyplots from matplotlib.)

IDLE won't start at all; it just opens X11.

I tried first using the 32 bit version of EPD and had the same issues before
I uninstalled and tried the 64 bit version.



--
View this message in context: http://enthought-dev.117412.n3.nabble.com/Errors-opening-IDLE-QtConsole-PyLab-tp4025509.html
Sent from the Enthought Dev mailing list archive at Nabble.com.
_______________________________________________
Enthought-Dev mailing list
[hidden email]
https://mail.enthought.com/mailman/listinfo/enthought-dev


_______________________________________________
Enthought-Dev mailing list
[hidden email]
https://mail.enthought.com/mailman/listinfo/enthought-dev



If you reply to this email, your message will be added to the discussion below:
http://enthought-dev.117412.n3.nabble.com/Errors-opening-IDLE-QtConsole-PyLab-tp4025509p4025510.html
To unsubscribe from Errors opening IDLE, QtConsole, PyLab, click here.
NAML

Reply | Threaded
Open this post in threaded view
|

Re: Errors opening IDLE, QtConsole, PyLab

Jonathan March
I'm guessing more detritus of the previous install; to find the offender, you could check what's on your system path; and from a command line try "which idle".

On Wed, Aug 15, 2012 at 4:32 PM, Josh Dempster <[hidden email]> wrote:
Jonathan,

Thanks! That fixed the issues with the pylab and other modules. However,
IDLE still won't start. Any ideas?

-Josh

On Wed, Aug 15, 2012 at 3:01 PM, Jonathan March [via Enthought Dev] <
[hidden email]> wrote:

> Josh,
>
> Looks like the detritus from your previous installation is getting in the
> way of your new installation.
> Delete or rename any .pth files in /Library/Python/2.7/site-packages/ and
> see whether that fixes it.
> When you type:
> >>> import sys; print sys.path
> there should be nothing listed from /Library/Python/
>
> hth,
> Jonathan
>
> On Wed, Aug 15, 2012 at 2:22 PM, Josh Dempster <[hidden email]<http://user/SendEmail.jtp?type=node&node=4025510&i=0>
> > wrote:
>
>> I'm a new python user who has been struggling to get a working
>> installation
>> of matplotlib before I tried Enthought. I'm on a Mac 10.7.3 trying to run
>> various modules after installing EPD 7.3-2 x86. When I try to run PyLab, I
>> get an import error:
>>
>>
>> dlopen(/Library/Python/2.7/site-packages/matplotlib-1.2.x-py2.7-macosx-10.8-intel.egg/matplotlib/backends/_macosx.so,
>> 2): Library not loaded:
>> /System/Library/Frameworks/CoreText.framework/Versions/A/CoreText
>>   Referenced from:
>>
>> /Library/Python/2.7/site-packages/matplotlib-1.2.x-py2.7-macosx-10.8-intel.egg/matplotlib/backends/_macosx.so
>>   Reason: image not found
>>
>> I get the same error running QtConsole. I checked, and CoreText.framework
>> just doesn't exist in Frameworks. (I also get this error trying to import
>> pyplots from matplotlib.)
>>
>> IDLE won't start at all; it just opens X11.
>>
>> I tried first using the 32 bit version of EPD and had the same issues
>> before
>> I uninstalled and tried the 64 bit version.
>>
>>
>>
>> --
>> View this message in context:
>> http://enthought-dev.117412.n3.nabble.com/Errors-opening-IDLE-QtConsole-PyLab-tp4025509.html
>> Sent from the Enthought Dev mailing list archive at Nabble.com.
>> _______________________________________________
>> Enthought-Dev mailing list
>> [hidden email] <http://user/SendEmail.jtp?type=node&node=4025510&i=1>
>> https://mail.enthought.com/mailman/listinfo/enthought-dev
>>
>
>
> _______________________________________________
> Enthought-Dev mailing list
> [hidden email] <http://user/SendEmail.jtp?type=node&node=4025510&i=2>
> https://mail.enthought.com/mailman/listinfo/enthought-dev
>
>
> ------------------------------
>  If you reply to this email, your message will be added to the discussion
> below:
>
> http://enthought-dev.117412.n3.nabble.com/Errors-opening-IDLE-QtConsole-PyLab-tp4025509p4025510.html
>  To unsubscribe from Errors opening IDLE, QtConsole, PyLab, click here< > .
> NAML<
http://enthought-dev.117412.n3.nabble.com/template/NamlServlet.jtp?macro=macro_viewer&id=instant_html%21nabble%3Aemail.naml&base=nabble.naml.namespaces.BasicNamespace-nabble.view.web.template.NabbleNamespace-nabble.view.web.template.NodeNamespace&breadcrumbs=notify_subscribers%21nabble%3Aemail.naml-instant_emails%21nabble%3Aemail.naml-send_instant_email%21nabble%3Aemail.naml>
>




--
View this message in context: http://enthought-dev.117412.n3.nabble.com/Errors-opening-IDLE-QtConsole-PyLab-tp4025509p4025512.html
Sent from the Enthought Dev mailing list archive at Nabble.com.
_______________________________________________
Enthought-Dev mailing list
[hidden email]
https://mail.enthought.com/mailman/listinfo/enthought-dev


_______________________________________________
Enthought-Dev mailing list
[hidden email]
https://mail.enthought.com/mailman/listinfo/enthought-dev
Reply | Threaded
Open this post in threaded view
|

Re: Errors opening IDLE, QtConsole, PyLab

chimpsarehungry
In reply to this post by Jonathan March
Jonathan and Josh,

Could you please help me fix this same problem. I recently installed the SciPy super pack  https://github.com/fonnesbeck/ScipySuperpack  and I am loving it.

And I am able to start iPython, import numpy, import scipy, import matplotlib etc. However, I am not able to use pylab or any plot functions. When I type $ ipython --pylab, I get the same problem Josh had. Shown below:

Python 2.7.1 (r271:86832, Jun 16 2011, 16:59:05) 
Type "copyright", "credits" or "license" for more information.

IPython 0.14.dev -- An enhanced Interactive Python.
?         -> Introduction and overview of IPython's features.
%quickref -> Quick reference.
help      -> Python's own help system.
object?   -> Details about 'object', use 'object??' for extra details.
[TerminalIPythonApp] GUI event loop or pylab initialization failed
---------------------------------------------------------------------------
ImportError                               Traceback (most recent call last)
/Library/Python/2.7/site-packages/ipython-0.14.dev-py2.7.egg/IPython/core/interactiveshell.pyc in enable_pylab(self, gui, import_all, welcome_message)
   2816         ns = {}
   2817         try:
-> 2818             gui = pylab_activate(ns, gui, import_all, self, welcome_message=welcome_message)
   2819         except KeyError:
   2820             error("Backend %r not supported" % gui)

/Library/Python/2.7/site-packages/ipython-0.14.dev-py2.7.egg/IPython/core/pylabtools.pyc in pylab_activate(user_ns, gui, import_all, shell, welcome_message)
    357                     ' Using %s instead.' % (gui, pylab_gui_select))
    358             gui, backend = find_gui_and_backend(pylab_gui_select)
--> 359     activate_matplotlib(backend)
    360     import_pylab(user_ns, import_all)
    361     if shell is not None:

/Library/Python/2.7/site-packages/ipython-0.14.dev-py2.7.egg/IPython/core/pylabtools.pyc in activate_matplotlib(backend)
    223     matplotlib.rcParams['backend'] = backend
    224 
--> 225     import matplotlib.pyplot
    226     matplotlib.pyplot.switch_backend(backend)
    227 

/Library/Python/2.7/site-packages/matplotlib-1.2.x-py2.7-macosx-10.8-intel.egg/matplotlib/pyplot.py in <module>()
     95 
     96 from matplotlib.backends import pylab_setup
---> 97 new_figure_manager, draw_if_interactive, _show = pylab_setup()
     98 
     99 @docstring.copy_dedent(Artist.findobj)

/Library/Python/2.7/site-packages/matplotlib-1.2.x-py2.7-macosx-10.8-intel.egg/matplotlib/backends/__init__.pyc in pylab_setup()
     23         backend_name = 'matplotlib.backends.%s'%backend_name.lower()
     24     backend_mod = __import__(backend_name,
---> 25                              globals(),locals(),[backend_name])
     26 
     27     # Things we pull in from all backends

/Library/Python/2.7/site-packages/matplotlib-1.2.x-py2.7-macosx-10.8-intel.egg/matplotlib/backends/backend_macosx.py in <module>()
     19 
     20 import matplotlib
---> 21 from matplotlib.backends import _macosx
     22 
     23 

ImportError: dlopen(/Library/Python/2.7/site-packages/matplotlib-1.2.x-py2.7-macosx-10.8-intel.egg/matplotlib/backends/_macosx.so, 2): Library not loaded: /System/Library/Frameworks/CoreText.framework/Versions/A/CoreText
  Referenced from: /Library/Python/2.7/site-packages/matplotlib-1.2.x-py2.7-macosx-10.8-intel.egg/matplotlib/backends/_macosx.so
  Reason: image not found

So I took your advice and changed the name of anything ending in .pth in /Library/Python/2.7/site-packages/
but that did not fix it.
Do you have any idea what this CoreText thing even is and why the library is not loading? Before re-installing the super pack, what all would I have to delete from my computer?

Thank you.

Shane
Reply | Threaded
Open this post in threaded view
|

Re: Errors opening IDLE, QtConsole, PyLab

Jonathan March
On Sat, Sep 1, 2012 at 1:26 PM, chimpsarehungry <[hidden email]> wrote:
Jonathan and Josh,

Could you please help me fix this same problem. I recently installed the
SciPy super pack  https://github.com/fonnesbeck/ScipySuperpack  and I am
loving it.

And I am able to start iPython, import numpy, import scipy, import
matplotlib etc. However, I am not able to use pylab or any plot functions.
When I type $ ipython --pylab, I get the same problem Josh had. Shown below:


I don't see anything below.
Also please include the contents of system path and sys.path.
 

So I took your advice and changed the name of anything ending in .pth in
/Library/Python/2.7/site-packages/
but that did not fix it.
Do you have any idea what this CoreText thing even is and why the library is
not loading? Before re-installing the super pack, what all would I have to
delete from my computer?

Thank you.

Shane



--
View this message in context: http://enthought-dev.117412.n3.nabble.com/Errors-opening-IDLE-QtConsole-PyLab-tp4025509p4025576.html
Sent from the Enthought Dev mailing list archive at Nabble.com.
_______________________________________________
Enthought-Dev mailing list
[hidden email]
https://mail.enthought.com/mailman/listinfo/enthought-dev


_______________________________________________
Enthought-Dev mailing list
[hidden email]
https://mail.enthought.com/mailman/listinfo/enthought-dev