Envisage entry points

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Envisage entry points

AndyGibson
This post has NOT been accepted by the mailing list yet.
I'm porting an application from an old python pack to pythonxy 2.7.9 which includes envisage 4.4.0.

I see envisageplugins is now deprecated and everything is bundled in envisage.

My problem is that the entry_points.txt in envisage-4.4.0-py2.7.egg-info does not include the WorkbenchPlugin as it did in envisageplugins-3.1.0n1-py2.5-win32.egg.

So without this entrypoint, the plugin isn't registered and my application won't work.

Can anyone explain why this has been excluded in the entry_points.txt; and the best way to resolve without making a modification egg info?

Thanks,
Andy