EPD on macosx 10.6

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

EPD on macosx 10.6

Mohammad Abdollahi
Hi

I'm trying to install EPD package (which i downloaded as a file named "epd-6.0.4-macosx-i386.dmg") for my Mac osx 10.6 from the scratch and I removed the /Library/Python/2.6 folder too prior to installation of EPD.  but after installation nothing works ! i cant import anything : scipy, numpy, enthought,...
besides, how can I make sure the installation is done 32-bit (everything including python) ? because i think this is necessary as wxpython only works 32-bit, right ?
thank for your comments in advance.

Best
Mohammad

_______________________________________________
Enthought-Dev mailing list
[hidden email]
https://mail.enthought.com/mailman/listinfo/enthought-dev
Reply | Threaded
Open this post in threaded view
|

Re: EPD on macosx 10.6

Peter Wang
On Sat, Feb 20, 2010 at 4:00 AM, Mohammad Abdollahi
<[hidden email]> wrote:
> Hi
>
> I'm trying to install EPD package (which i downloaded as a file named
> "epd-6.0.4-macosx-i386.dmg") for my Mac osx 10.6 from the scratch and I
> removed the /Library/Python/2.6 folder too prior to installation of EPD.
> but after installation nothing works ! i cant import anything : scipy,
> numpy, enthought,...

Can you run "python" at the command prompt?  If so, can you do "import
sys; print sys.prefix" and report what it says?

You should also "import sys; print sys.path".  In the output, you
should see a bunch of directories with 'site-packages' in their name.
What is the location of this site-packages directory?

For future reference, note that you should not need to uninstall the
system Python2.6 - EPD installs parallel to the system one, as a
separate framework.

-Peter
_______________________________________________
Enthought-Dev mailing list
[hidden email]
https://mail.enthought.com/mailman/listinfo/enthought-dev
Reply | Threaded
Open this post in threaded view
|

Re: EPD on macosx 10.6

Mohammad Abdollahi
Dear Peter,

thank you for the reply. I did what you said and here's the output :

>>> import sys
>>> print sys.prefix
/Library/Frameworks/Python.framework/Versions/6.0.4
>>> import sys
>>> print sys.path
['', '/Library/Frameworks/Python.framework/Versions/6.0.4/lib/python26.zip', '/Library/Frameworks/Python.framework/Versions/6.0.4/lib/python2.6', '/Library/Frameworks/Python.framework/Versions/6.0.4/lib/python2.6/plat-darwin', '/Library/Frameworks/Python.framework/Versions/6.0.4/lib/python2.6/plat-mac', '/Library/Frameworks/Python.framework/Versions/6.0.4/lib/python2.6/plat-mac/lib-scriptpackages', '/Library/Frameworks/Python.framework/Versions/6.0.4/lib/python2.6/lib-tk', '/Library/Frameworks/Python.framework/Versions/6.0.4/lib/python2.6/lib-old', '/Library/Frameworks/Python.framework/Versions/6.0.4/lib/python2.6/lib-dynload', '/Library/Frameworks/Python.framework/Versions/6.0.4/lib/python2.6/site-packages', '/Library/Frameworks/Python.framework/Versions/6.0.4/lib/python2.6/site-packages/PIL']

thanks
Mohammad

On Sun, Feb 21, 2010 at 4:11 PM, Peter Wang <[hidden email]> wrote:
On Sat, Feb 20, 2010 at 4:00 AM, Mohammad Abdollahi
<[hidden email]> wrote:
> Hi
>
> I'm trying to install EPD package (which i downloaded as a file named
> "epd-6.0.4-macosx-i386.dmg") for my Mac osx 10.6 from the scratch and I
> removed the /Library/Python/2.6 folder too prior to installation of EPD.
> but after installation nothing works ! i cant import anything : scipy,
> numpy, enthought,...

Can you run "python" at the command prompt?  If so, can you do "import
sys; print sys.prefix" and report what it says?

You should also "import sys; print sys.path".  In the output, you
should see a bunch of directories with 'site-packages' in their name.
What is the location of this site-packages directory?

For future reference, note that you should not need to uninstall the
system Python2.6 - EPD installs parallel to the system one, as a
separate framework.

-Peter
_______________________________________________
Enthought-Dev mailing list
[hidden email]
https://mail.enthought.com/mailman/listinfo/enthought-dev


_______________________________________________
Enthought-Dev mailing list
[hidden email]
https://mail.enthought.com/mailman/listinfo/enthought-dev
Reply | Threaded
Open this post in threaded view
|

Re: EPD on macosx 10.6

Mohammad Abdollahi
working now !! thank s a lot for the help.

Mohammad

On Sun, Feb 21, 2010 at 5:09 PM, Mohammad Abdollahi <[hidden email]> wrote:
Dear Peter,

thank you for the reply. I did what you said and here's the output :

>>> import sys
>>> print sys.prefix
/Library/Frameworks/Python.framework/Versions/6.0.4

>>> import sys
>>> print sys.path
['', '/Library/Frameworks/Python.framework/Versions/6.0.4/lib/python26.zip', '/Library/Frameworks/Python.framework/Versions/6.0.4/lib/python2.6', '/Library/Frameworks/Python.framework/Versions/6.0.4/lib/python2.6/plat-darwin', '/Library/Frameworks/Python.framework/Versions/6.0.4/lib/python2.6/plat-mac', '/Library/Frameworks/Python.framework/Versions/6.0.4/lib/python2.6/plat-mac/lib-scriptpackages', '/Library/Frameworks/Python.framework/Versions/6.0.4/lib/python2.6/lib-tk', '/Library/Frameworks/Python.framework/Versions/6.0.4/lib/python2.6/lib-old', '/Library/Frameworks/Python.framework/Versions/6.0.4/lib/python2.6/lib-dynload', '/Library/Frameworks/Python.framework/Versions/6.0.4/lib/python2.6/site-packages', '/Library/Frameworks/Python.framework/Versions/6.0.4/lib/python2.6/site-packages/PIL']

thanks
Mohammad


On Sun, Feb 21, 2010 at 4:11 PM, Peter Wang <[hidden email]> wrote:
On Sat, Feb 20, 2010 at 4:00 AM, Mohammad Abdollahi
<[hidden email]> wrote:
> Hi
>
> I'm trying to install EPD package (which i downloaded as a file named
> "epd-6.0.4-macosx-i386.dmg") for my Mac osx 10.6 from the scratch and I
> removed the /Library/Python/2.6 folder too prior to installation of EPD.
> but after installation nothing works ! i cant import anything : scipy,
> numpy, enthought,...

Can you run "python" at the command prompt?  If so, can you do "import
sys; print sys.prefix" and report what it says?

You should also "import sys; print sys.path".  In the output, you
should see a bunch of directories with 'site-packages' in their name.
What is the location of this site-packages directory?

For future reference, note that you should not need to uninstall the
system Python2.6 - EPD installs parallel to the system one, as a
separate framework.

-Peter
_______________________________________________
Enthought-Dev mailing list
[hidden email]
https://mail.enthought.com/mailman/listinfo/enthought-dev



_______________________________________________
Enthought-Dev mailing list
[hidden email]
https://mail.enthought.com/mailman/listinfo/enthought-dev