AlreadyImportedError while importing traitsui.api

classic Classic list List threaded Threaded
10 messages Options
Reply | Threaded
Open this post in threaded view
|

AlreadyImportedError while importing traitsui.api

Jagannathan Tiruvallur Eachambadi
Hi all

I checked around and I found that this problem was to fail silently. More specifically I get this problem while trying to use <https://github.com/sfepy/sfepy/blob/master/sfepy/postprocess/viewer.py>. I tried to import traitsui.api alone in ipython and I get the same error. So I can assume that it does not come stefy. Any ideas to fix it?

Regards
jagan

_______________________________________________
Enthought-Dev mailing list
[hidden email]
https://mail.enthought.com/mailman/listinfo/enthought-dev
Reply | Threaded
Open this post in threaded view
|

Re: AlreadyImportedError while importing traitsui.api

Jonathan March
Jagan,

No, this is not normal. 

Please provide much more detail about your environment and versions of all relevant packages.

Jonathan 


On Mon, Feb 10, 2014 at 5:22 AM, Jagannathan Tiruvallur Eachambadi <[hidden email]> wrote:
Hi all

I checked around and I found that this problem was to fail silently. More specifically I get this problem while trying to use <https://github.com/sfepy/sfepy/blob/master/sfepy/postprocess/viewer.py>. I tried to import traitsui.api alone in ipython and I get the same error. So I can assume that it does not come stefy. Any ideas to fix it?

Regards
jagan

_______________________________________________
Enthought-Dev mailing list
[hidden email]
https://mail.enthought.com/mailman/listinfo/enthought-dev



_______________________________________________
Enthought-Dev mailing list
[hidden email]
https://mail.enthought.com/mailman/listinfo/enthought-dev
Reply | Threaded
Open this post in threaded view
|

Re: AlreadyImportedError while importing traitsui.api

Jagannathan Tiruvallur Eachambadi
Jagan,

No, this is not normal. 

Please provide much more detail about your environment and versions of all relevant packages.

Jonathan 

I use ArchLinux and these are the packages. with version numbers.
python2-pyface 4.4.0-2
python2-traits 4.4.0-1
python2-traitsui 4.4.0-1
wxpython 3.0.0.0-2
wxpython2.8 2.8.12.1-1

These packages were installed from the official repository.
Regards
Jagan

_______________________________________________
Enthought-Dev mailing list
[hidden email]
https://mail.enthought.com/mailman/listinfo/enthought-dev
Reply | Threaded
Open this post in threaded view
|

Re: AlreadyImportedError while importing traitsui.api

Didrik Pinte-2
The AlreadyImportedError comes from wx. It sounds like you have an issue while selecting the version of WX. Without digging into the details, I suspect that you should either have 2.8 or 3.0 installed and not both.

-- Didrik


On 12 February 2014 11:12, Jagannathan Tiruvallur Eachambadi <[hidden email]> wrote:
Jagan,

No, this is not normal. 

Please provide much more detail about your environment and versions of all relevant packages.

Jonathan 

I use ArchLinux and these are the packages. with version numbers.
python2-pyface 4.4.0-2
python2-traits 4.4.0-1
python2-traitsui 4.4.0-1
wxpython 3.0.0.0-2
wxpython2.8 2.8.12.1-1

These packages were installed from the official repository.
Regards
Jagan

_______________________________________________
Enthought-Dev mailing list
[hidden email]
https://mail.enthought.com/mailman/listinfo/enthought-dev



_______________________________________________
Enthought-Dev mailing list
[hidden email]
https://mail.enthought.com/mailman/listinfo/enthought-dev
Reply | Threaded
Open this post in threaded view
|

Re: AlreadyImportedError while importing traitsui.api

Jagannathan Tiruvallur Eachambadi
On Wed, Feb 12, 2014 at 4:06 PM, Didrik Pinte <[hidden email]> wrote:
The AlreadyImportedError comes from wx. It sounds like you have an issue while selecting the version of WX. Without digging into the details, I suspect that you should either have 2.8 or 3.0 installed and not both.

-- Didrik

Pacman says wxpython2.8 requires wxpython and  mayavi requires wxpython2.8. So, I don't know what to remove.

Regards

Jagan

_______________________________________________
Enthought-Dev mailing list
[hidden email]
https://mail.enthought.com/mailman/listinfo/enthought-dev
Reply | Threaded
Open this post in threaded view
|

Re: AlreadyImportedError while importing traitsui.api

Didrik Pinte-2



On 12 February 2014 11:54, Jagannathan Tiruvallur Eachambadi <[hidden email]> wrote:
On Wed, Feb 12, 2014 at 4:06 PM, Didrik Pinte <[hidden email]> wrote:
The AlreadyImportedError comes from wx. It sounds like you have an issue while selecting the version of WX. Without digging into the details, I suspect that you should either have 2.8 or 3.0 installed and not both.

-- Didrik

Pacman says wxpython2.8 requires wxpython and  mayavi requires wxpython2.8. So, I don't know what to remove.

You listed this package : wxpython 3.0.0.0-2. Can you remove it?

_______________________________________________
Enthought-Dev mailing list
[hidden email]
https://mail.enthought.com/mailman/listinfo/enthought-dev
Reply | Threaded
Open this post in threaded view
|

Re: AlreadyImportedError while importing traitsui.api

Jagannathan Tiruvallur Eachambadi


On Feb 12, 2014 6:57 PM, "Didrik Pinte" <[hidden email]> wrote:
>
>
>
>
> On 12 February 2014 11:54, Jagannathan Tiruvallur Eachambadi <[hidden email]> wrote:
>>
>> On Wed, Feb 12, 2014 at 4:06 PM, Didrik Pinte <[hidden email]> wrote:
>>>
>>> The AlreadyImportedError comes from wx. It sounds like you have an issue while selecting the version of WX. Without digging into the details, I suspect that you should either have 2.8 or 3.0 installed and not both.
>>>
>>> -- Didrik
>>
>>
>> Pacman says wxpython2.8 requires wxpython and  mayavi requires wxpython2.8. So, I don't know what to remove.
>>
> You listed this package : wxpython 3.0.0.0-2. Can you remove it?
>
>
The package manager says wxpython2.8 requires wxpython.

Regards
Jagan


_______________________________________________
Enthought-Dev mailing list
[hidden email]
https://mail.enthought.com/mailman/listinfo/enthought-dev
Reply | Threaded
Open this post in threaded view
|

Re: AlreadyImportedError while importing traitsui.api

Didrik Pinte-2



On 12 February 2014 14:47, Jagannathan Tiruvallur Eachambadi <[hidden email]> wrote:


On Feb 12, 2014 6:57 PM, "Didrik Pinte" <[hidden email]> wrote:
>
>
>
>
> On 12 February 2014 11:54, Jagannathan Tiruvallur Eachambadi <[hidden email]> wrote:
>>
>> On Wed, Feb 12, 2014 at 4:06 PM, Didrik Pinte <[hidden email]> wrote:
>>>
>>> The AlreadyImportedError comes from wx. It sounds like you have an issue while selecting the version of WX. Without digging into the details, I suspect that you should either have 2.8 or 3.0 installed and not both.
>>>
>>> -- Didrik
>>
>>
>> Pacman says wxpython2.8 requires wxpython and  mayavi requires wxpython2.8. So, I don't know what to remove.
>>
> You listed this package : wxpython 3.0.0.0-2. Can you remove it?
>
>
The package manager says wxpython2.8 requires wxpython.
 
If 2.8 requires 3.0 ... there is something wrong in your package manager.

-- Didrik 

_______________________________________________
Enthought-Dev mailing list
[hidden email]
https://mail.enthought.com/mailman/listinfo/enthought-dev
Reply | Threaded
Open this post in threaded view
|

Re: AlreadyImportedError while importing traitsui.api

John Tyree
I use arch at home and can play with this, but not until later tonight.


On Wed, Feb 12, 2014 at 8:42 AM, Didrik Pinte <[hidden email]> wrote:



On 12 February 2014 14:47, Jagannathan Tiruvallur Eachambadi <[hidden email]> wrote:


On Feb 12, 2014 6:57 PM, "Didrik Pinte" <[hidden email]> wrote:
>
>
>
>
> On 12 February 2014 11:54, Jagannathan Tiruvallur Eachambadi <[hidden email]> wrote:
>>
>> On Wed, Feb 12, 2014 at 4:06 PM, Didrik Pinte <[hidden email]> wrote:
>>>
>>> The AlreadyImportedError comes from wx. It sounds like you have an issue while selecting the version of WX. Without digging into the details, I suspect that you should either have 2.8 or 3.0 installed and not both.
>>>
>>> -- Didrik
>>
>>
>> Pacman says wxpython2.8 requires wxpython and  mayavi requires wxpython2.8. So, I don't know what to remove.
>>
> You listed this package : wxpython 3.0.0.0-2. Can you remove it?
>
>
The package manager says wxpython2.8 requires wxpython.
 
If 2.8 requires 3.0 ... there is something wrong in your package manager.

-- Didrik 

_______________________________________________
Enthought-Dev mailing list
[hidden email]
https://mail.enthought.com/mailman/listinfo/enthought-dev




--
John Tyree
Scientific Software Developer
Enthought, Inc.

www.enthought.com

_______________________________________________
Enthought-Dev mailing list
[hidden email]
https://mail.enthought.com/mailman/listinfo/enthought-dev
Reply | Threaded
Open this post in threaded view
|

Re: AlreadyImportedError while importing traitsui.api

Jagannathan Tiruvallur Eachambadi
I solved it by installing wxpython2.8 from aur and uninstalled wxpython. I'll keep it this way until the package manager decides to split wxversion, https://bbs.archlinux.org/viewtopic.php?id=176004 .

Regards,
Jagan

_______________________________________________
Enthought-Dev mailing list
[hidden email]
https://mail.enthought.com/mailman/listinfo/enthought-dev